8

I erased my disk while planing to reinstall the OS. Now I get the recovery screen as planed, I press "Reinstall OS X" and then press on "Continue". It checks my eligibility and tells me "Could not find installation information for this machine".

Obviously I cannot go back because the disk is already erased, and I have no time machine backups.

  • I do remember having this issue in the past, and all I had to do is login to the AppStore. But now this is kinda not relevant (and I was logged in before I erased the disk)
1
  • Problem solved by asking a friend to make a bootable USB and installing from there. Thanks for the answers. Commented Sep 7, 2016 at 14:36

8 Answers 8

10

I resolved this issue by changing the Wi-Fi network I was connected to. I was on xfinitywifi which was requiring a registration I didn't see. As soon as I connected to my internal company Wi-Fi network without a click-through screen it worked.

Other avenues to resolve this are making a bootable installer, booting from recovery or otherwise connecting to a new network if that’s causing the issue (Ethernet instead of WiFi for instance)

2
  • My network also had a 'agree to network usage terms' box that needed to be clicked on before you were allowed to surf the Internet. This was preventing me to access the Internet and hence creating the fail condition.
    – learnerX
    Commented Apr 17, 2017 at 21:04
  • I really didn't think this was going to be the reason, because I had launched internet recovery using my home network, but what do you know! Commented Dec 13, 2017 at 1:08
2

If you are installing mac os on a fresh Hard Drive then rather pressing cmd+R on startup, you need to press and hold only alt/opt key on system startup.

2

Another method for those that might not have access to another Mac: I created a Hotspot without any security on my phone and connected the Mac to it for the activation part. Worked like a charm for me.

2

Check your wireless connection. Erasing the disks erases the WiFi information on the drive (it's located in your keychain), so when it reboots, it simply looks for the nearest WiFi SSID it can find, which may not be the right one. Click on the WiFi icon in the upper right hand corner and choose the correct SSID, then feed it any credentials it asks for. When it has the correct WiFi, try again.

0

The only way out of this mess that I found was asking a friend to make me an installation USB, and use that to install the new OS.

Apple was not very clever with this, they could have made it possible to sign into the AppStore from the recovery screen as you obviously will reach it when you need to (re)install the OS...

0

I had tried three times through the internet installation. First attempt I spent three hours. My second attempt was five hours and the final attempt I wasn’t sure because I had left my notebook at home.

-1

Just keep trying. It took me 10 times before it finally went through. No USB needed, just bad connection to the Apple server!

-1

Simply click the WiFi logo (top right) and select Join Other Network. Then type in the SSID of your network, select your security, then type in your password and you’re good to go to reinstall OS.

1
  • What does the wifi have to do with the OP's problem?
    – fsb
    Commented Jan 20, 2021 at 13:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .