0

Inherited a MacBook Pro (2010 MacBook6,1 17"). Starts up fine, but wouldn't boot - no operating system found. Hard drive does not appear to be bad (see details below) but I can't seem to get it to accept an OS installation. What I've tried so far:

  1. Starting system using my 13" MBP as host drive in Target Disk Mode (intent was to check system hardware before I tried anything else) - would not boot, some type of error message appears over the loading screen, system reboots too quickly to read it.
  2. Placing 17" MBP in Target Disk Mode - My 13" reads the disk just fine, Disk Utility sees no errors in the volume, reformatting the volume gives no errors
  3. Starting from included OS X 10.6 installation DVD - Loads fine, Disk Utility shows no errors, installation initiates correctly, but exits with an error stating the installation could not complete on this system.
  4. Cloning Recovery Partition from the 13" MBP (using CarbonCopy Cloner) - Will not boot, same text error as encountered using 13" in Target Disk Mode
  5. Internet Recovery - system initiates recovery, but immediately throws a "-6002F" error
  6. Starting in Single User Mode didn't highlight any obvious errors that I could see.

So... what next? I have NOT tried resetting PRAM or SMC. I do have another hard drive that I could swap in if needed (currently this drive is inside a 2007 MBP with a dead motherboard, so swapping it would require removal of 37,000 tiny screws). I probably have some memory that would be compatible, if it's an issue there, as it appears to take the same specs as my 13", but am hoping that's not the problem (I upgraded the 13" from 4 to 16 GB RAM, 17" currently has 8 GB, so swapping it could cut the memory in half, depending on DIMM arrangement - I haven't cracked the case yet to check).

Suggestions?

1

Appears to have been a bad memory module. I swapped in a known good hard drive (with OS already installed) with no success, reset PRAM (which restored startup sound) but didn't help the boot process. However, as soon as I pulled the RAM and replaced with a known good pair of DIMMs it booted right up. (Unfortunately that also means I went from 8 GB to 2 GB RAM - so I think I'll be placing an order for an upgrade!)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .