1

When I run brew doctor It says

Warning: Your Xcode (6.4) is outdated
Please update to Xcode 7.3.1.
Xcode can be updated from the App Store.

While I already have latest XCode cli, which I found out by running pkgutil --pkg-info=com.apple.pkg.CLTools_Executables which says:

package-id: com.apple.pkg.CLTools_Executables
version: 7.3.1.0.1.1461711523
volume: /
location: /
install-time: 1466534515
groups: com.apple.FindSystemFiles.pkg-group com.apple.DevToolsBoth.pkg-group com.apple.DevToolsNonRelocatableShared.pkg-group 

How to I fix it ?

1

The problem here is just simply that brew is detecting an old version of Xcode. If it was objecting to the version of the command line tools that you have installed you'd be getting a different error message.

A newer Command Line Tools release is available.
Update them from Software Update in the App Store.

You can see the actual code here yourself. The checks for Xcode and the command line tools are separate.

The way to fix this message from brew doctor is either to remove the old version of Xcode or update it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .