So from the left side of the Finder I accidentally dragged my external hard drive and now it doesn't appear there. I would like to see it there, I know it's reading it because I did an ls /Volumes and it's there. How do I put the drive back in the Sidebar?

Note 1: I tried to command+shift+G and went to /Volumes and tried to drag it in place that won't work, what do I do?

Note 2: It's not "Choose Preferences from the Finder menu, click on Sidebar, and check the box for it". The problem is with one particular external drive, I dragged it out of Finder and can't put it back.

  • Are you sure that your "Note 2" doesn't work? Try unchecking the box next to "Hard Drives" in the preferences and then checking it again. If that doesn't work try restarting after having the box checked. – jan Jun 23 '16 at 10:16
  • Its not that it's that I dragged the shortcut out, so it won't reappear (its one disk in particular that I dragged out and won't automatically appear i need to goto the direction that contains all disks). – De-Novo Jun 23 '16 at 18:12
  • Please try this: Open Finder Prefs, Un-check Harddrives box in the Sidebar options. Close Prefs. Restart Finder (or log out log in). Open Finder Prefs, now check Harddrives box in the Sidebar options. Close Prefs. Restart Finder (or log out log in) again. Post back results. – jan Jun 23 '16 at 18:53
  • I tried it, I still can't see this particular external drive, in devices. (note: I can see any other drive automatically because the box is check.) – De-Novo Jun 24 '16 at 5:20
  • That's bizarre. Have you tried restarting (instead of logging out and logging in in my suggestion above)? If that doesn't help try running the maintenance scripts with Onyx. – jan Jun 24 '16 at 14:31

I had the exact same issue. Here's the solution: open a Terminal and do the following:

open /Volumes/[Your external hard drive]

This will open up a Finder window which shows your Volumes, including the external drive. Just select and drag the drive back to the left panel, under Devices.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .