I have a Western Digital My Passport Ultra 1 TB external hard drive that is formatted FAT32 and a 16 GB Silicon Power USB thumb drive and both of them uses USB3 but my MacBook Pro sometimes doesn't recognise them and I have to remove them or restart MacBook several times until they show up.

What could be the problem?

Specs: MacBookPro12,1 2015 with OS X 10.11.5

  • 3
    It is helpful if you provided some key information like MBP model and year, which version of OS X you are using, etc. Remember, we're not there to look over your shoulder. Also, can you expand on the external drive as well? What do you mean "restart several times"? Are you referring to the drive or to the MBP?
    – Allan
    Jun 22, 2016 at 20:14
  • 2
    Year? Try this...in Terminal, issue the command system_profiler SPHardwareDataType | grep -i identifier and post the results.
    – Allan
    Jun 22, 2016 at 20:24
  • post edited @Allan
    – Amir_P
    Jun 23, 2016 at 11:36
  • 1
    There's still lots of details still missing, Please reread the comments.
    – Allan
    Jun 23, 2016 at 14:33
  • @Allan I've edited my post and added my hards details but it happens with my 16 gb silicon power usb drive
    – Amir_P
    Jun 23, 2016 at 17:10

4 Answers 4


There can be a number of reasons why your Macbook Pro won't recognize a drive.

For instance, if you have a drive mounted and your system goes to sleep, it will also power down the USB port, putting your drive to sleep. When your Mac wakes up again, the drive may not have come out of its slumber.

To verify that your USB port is detecting devices, open "Console" (Applications > Utilities > Console). For example, I inserted a Windows (FAT16) formatted USB flash drive that doesn't mount and doesn't show on my desktop. However, in Console, you can see that it is detected and an error is generated:

enter image description here

When you attach your USB devices, have Console running and watch to see if the device is detected and whether an error is generated. If nothing happens here (with both devices) then you have ruled out your USB devices.

If they are being recognized in the system, but not showing up, you may have to disconnect them and remount them in Terminal.

First, see if they are listed. Issue the command

diskutil list

My relevant output, again using my non-mountable USB as an example is as follows:

/dev/disk4 (disk image):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:     Apple_partition_scheme                        +15.6 MB    disk4
   1:        Apple_partition_map                         32.3 KB    disk4s1
   2:                  Apple_HFS True Key                15.6 MB    disk4s2
/dev/disk5 (external, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:     FDisk_partition_scheme                        *8.0 GB     disk5
   1:             Windows_FAT_16                         2.1 GB     disk5s1 <----- My Problem Child

Eject the disk using the command

diskutil eject disk5

(Obviously use the disk number that associated with your USB device)

Running diskutil list again shows the device is gone:

/dev/disk4 (disk image):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:     Apple_partition_scheme                        +15.6 MB    disk4
   1:        Apple_partition_map                         32.3 KB    disk4s1
   2:                  Apple_HFS True Key                15.6 MB    disk4s2

Now, physically remove, then reinsert the USB drive. Your drive should be functioning again.

  • 1
    This is really helpful, thank you. When I tried to eject my disk, it gave the message Volume timed out while waiting to eject. any ideas?
    – Nova
    Mar 26, 2017 at 14:39
  • @Nova - something could be causing it to be "busy" - an open file or a process is preventing it from ejecting. Try unmounting the drive instead of ejecting: sudo diskutil unmountDisk diskX It will still show up in diskutil, but you will be able to remove it without causing any issues.
    – Allan
    Mar 26, 2017 at 17:54
  • thanks @Allan. I've tried your suggestion but terminal hangs when it asks me for my password with sudo. Unmounting without sudo I get the same "Volume timed out" message. If you have time to take a look I provided more details in my own question, I'd really appreciate your advice! apple.stackexchange.com/questions/277541/…
    – Nova
    Mar 26, 2017 at 20:55
  • 1
    I had the same problem and I tried all the magic (beyond this answer), I could not get My Passport WD to work (light was ON but not blinking), I then simply "inserted" the USB3 very slowly in MBP and it works, its so weird; can not explain this phenomenon (I also blew some air in both end of cable).
    – Kyslik
    Jul 25, 2017 at 11:35
  • I had similar problems, tried unplugging and plugging back in at least 5 times. As always a reboot made the drive reappear, such an incredibly annoying issue.
    – dom96
    Apr 24, 2018 at 16:50

First, see if it appears in Disk Utility. If it appears but is not mounted, you can select the mount option which should mount your disk. Then, click on the Apple logo in the top left corner and select about my Mac. It should appear under storage. Also try going to the system report under the overview tab. Sometimes the lag can occur because fsck is running on it to repair any possible damage/recovery tools. People have also reported that it might not be receiving enough power if you have to plug it in.

Side notes: This is commonly caused when the disk is removed without first ejecting

  • 1
    fsck is what did it! it was preventing my machine from ejecting the disk and from mounting the volume. sudo pkill -f fsck was enough to kill mac "trying to fix" the volume and let it show up as needed. Feb 6, 2018 at 5:28

Have you dropped your mbp ? I dropped mine once and the cable connecting the right side ports wasn't truly connected anymore. This lead to external hdds not being recognised and once recognised disconnecting without prompt.


Something else to check:

  • Did you use the external hard disk correctly?

In my situation, that was the problem! Here is what I did wrong: I turned on the external HD case's power button, and then I plugged the USB cable into my Mac. I believed that you must always have power on your devices before plugging them into the Mac. But no drive showed up! Sometimes it worked but I didn't know why. Usually a Mac restart fixed it... I lived with this... for a long time.

But today I realized that the proper method for my external drive is:

  • Turn OFF the external drive (if it's on).
  • Plug in the USB cable into the Mac.
  • Turn ON the external drive when the USB cable is connected.

My drive will ONLY initialize itself as a "talking to the computer" hard drive if I have the USB cable plugged into the Mac at the exact moment that I am turning the external drive on.

I'm using a two-drive USB hard disk case. And it turns out that if I start the case WITHOUT having my USB cable plugged into my Mac already, then the case enters some kind of "clone drive A to drive B" solo-mode where it won't talk to the computer at all.

So I am just adding this answer for others that have the same situation. Try plugging your USB cable in FIRST, and THEN power on the external drive. That may be all it takes to solve it for you like it did for me!

PS: Big thanks for @Allan who suggested that I look in the Console log. That was how I discovered that my USB device was detected by the computer but advertised no storage units. :) Some more fiddling later, I had realized that this particular drive enclosure's external storage mode is only activated if the Mac is already connected before powering on the drive.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .