0

I have an iPhone 5S and was messing with my settings and cannot figure out what I did. Whenever I text another iPhone user, my message comes over in gray instead of blue, and it comes over sent from my email instead of an iMessage. I checked my settings and my iMessage is on. I don't know where to come from here. Can anyone walk me thru the process to correct this glitch? Incidentally, this just started happening after I updated to the iOS 9.3.2.

Thanks,

  • In Settings > Messages > Send & Receive - Are your cellphone number and your email address both listed? Is iMessage enabled? – TMHahn Jun 20 '16 at 23:46
  • iMessafe is enabled, and email and phone number are both chercked – ShelleyL Jun 20 '16 at 23:52
  • I just tried to remove the email address and it wouldn't allow it – ShelleyL Jun 20 '16 at 23:53
1

Messages are always received in grey, regardless of if they are iMessages (from a phone number or email address) or text messages.

But to get the messages sending from your number, not your email:

  1. Go to Settings
  2. Scroll down and tap "Messages"
  3. Scroll down and tap "Send & Receive"
  4. Make sure only your phone number is checked off in the "Start New Conversations From" section. (It may also be worth unchecking your email address(es) from the "You Can Be Reached By iMessage At" section as well... though I don't think this should be required).
  • Happy to hear it! – McHobbes Jun 21 '16 at 0:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .