1

TL;DR

Waking OS X computer A on the network, wakes OS X computer B. Plugging in an iOS device to charge, wakes B too. Prevent this.

Problem

I keep my iMac in my bedroom, and just before I'm about to go to sleep I use my MacBook Pro for a while. I also connect my iPhone to the lightning connector to charge it over the night.

Both opening the MacBook Pro from sleep, and putting the iPhone to charge, has the incredibly annoying behavior of waking my iMac from sleep mode. So even if I've set the iMac to sleep, if I open the lid on my MacBook or plug in the phone, my iMac wakes, and its loud fans are disturbing. I've set my iMac to sleep automatically after 30 minutes, so I always have to go up and make it go to sleep again.

Why does the iMac exhibit this behavior? How do I stop it?

I think that when an iPhone gets connected to a charger, it wakes the iMac to Wi-fi sync to iTunes. Similarly, it may be that because I have my MacBook connected to a shared iTunes library on my iMac, that might be waking the iMac – but I'm not sure yet.


Note: Disabling Wake for Wi-Fi network access under Settings > Energy Saver does not prevent this behavior, from what I have gathered.


Temporary solution

If there is anyone else having this problem, this is the quick-fix solution (SSH/VNC) I am using at the moment. There are VNC apps for iOS, and in OS X there is the native Screen Sharing application or third-party alternatives, or the plain old Terminal for remote control.

  • 1
    If the iMac is connected via wifi, try going into Settings --> Energy Saver and uncheck Wake for WiFi Network Access. See if that helps. – fsb Jun 20 '16 at 21:09
  • @fbara Sure, but wouldn't that also prevent me from WOL when I really do need it? – Winterflags Jun 20 '16 at 21:11
  • Yes, but I think that's your problem. Plugging in your iPhone or opening your Mac is waking-up any shared service or connections causing your iMac to wake up. – fsb Jun 20 '16 at 21:14
  • Disabling Wake for WiFi Network Access does not prevent this issue from occurring, strangely. – Winterflags Jul 3 '16 at 23:05
  • 1
    What happens if you set your phone to not sync by wifi? That is a different setting than don't wake for wifi. – Harper Jul 10 '16 at 23:32
1

Under Device Backups, in iTunes 12.4.1 Preferences, there is a checkbox "Prevent iPods,iPhone & iPads from syncing automatically". That should help.

-1

Disable "itunes agent" at login items

  • Welcome to Ask Different. We like answers to be more than just a single line. Ideally, you want to explain why your answer is *right." It also helps to provide links, citations, and/or screen shots. Please review our help section How to Answer on writing good answers to questions – Allan Jul 10 '16 at 10:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .