I've been having some issues with an iMac running El Capitan. The issue seems to be Finder. I tried leaving it to shut down by itself overnight to no avail.

On occasion I get this message: The screenshot below is Dutch but says something along the lines of:

Your Mac was not shut down because Finder could not be stopped. Please quit ?Finder to continue.

enter image description here

Things I've tried

  • I've tried shutting it down with a hard reset (power button and a shutdown command from terminal) and restarting.
  • I've tried disk repair in recovery mode,
  • I've tried resetting NVRAM.
  • I've tried shutting down Finder with the usual suspects: Force Quit, killall Finder.

This last one does something, but definitely not what I expect:

enter image description here

It looks like Finder has quit, it's no longer in the list activity monitor. Relaunching it with terminal command open . in the user home folder gives the error:

LSOpenURLsWithRole() failed with error -600...

Don't know how to fix it anymore. Any advice?

  • Is this the exclusive time this has happened, or is this beyond an isolated incident?
    – JMY1000
    Jun 20, 2016 at 8:37
  • Hi @JMY1000, it's not isolated in the sense that it doesn't go away no matter what I try. Otherwise I wouldn't need to ask you guys ;) It is isolated in the sense that it's the only Mac I know with this issue.
    – Jorg
    Jun 20, 2016 at 9:21
  • Is it the only time it's happened with this Mac?
    – JMY1000
    Jun 20, 2016 at 9:51
  • It's the first time it's happened to this Mac, yes. It's fairly new, perhaps 6 months.
    – Jorg
    Jun 20, 2016 at 9:52
  • Just a quick question, did you tried to use cmd+alt+escape and kill finder ? This occasionally happens with the mail app but not finder.. I'm afraid a re-install will fix this issue.
    – rwzdoorn
    Jun 20, 2016 at 10:31

4 Answers 4


My issue turned out to be in an outdated Wacom driver. After removing it, Mac worked fine. I guess formatting would have sorted it out too.


To re-run Finder, try:

launchctl stop com.apple.Finder
launchctl start com.apple.Finder

Then try to run it as: open -a Finder.

For further troubleshooting, you can run the app in the foreground and check for any errors:


Consider also checking the logs via log stream command. Also, disconnect any external drives to be sure (e.g. diskutil umount force /Volumes/MyDrive).

If you suspect any damaged files, it's good to rsync above files from another working macOS or try to reinstall.


I wasn't able to use finder to shut down or restart my macbook air after upgrading to El Capitan until I did a hard shut down and restarted in safe mode (hold down the shift key when restarting). Logged in as usual, then used finder to restart. Everything is working as it should now.


In order to properly quit finder, you need to open Activity Monitor. Once you’re in the app, select "Finder". Find the "x" at the top, and select "Quit" or "Force Quit".

Also wrote this from an earlier question today.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .