2

While I'm coping the file from the External hard drive to my MacBook Pro I'm getting Error code -36. Some recommended for dot_clean option, also I've tried and facing the same issue. Even I've tried to copy through the Terminal and also getting IO error. Desperately need to copy my stuff from my external drive.

  • What does "Some recommended for dot_clean option, also I've tried and facing the same issue." mean. Also how is the external disk connected and how is it formatted. What is the exact output in the terminal – Mark Jun 20 '16 at 11:34
  • dot_clean option is to remove the .DS_Store hidden file from the folder. WD My Book 2TB External Hard Drive Storage USB 3.0 with External Power Adapter. The format type is FAT32. Error msg in the system.log Jun 20 06:55:27 Gowthamans-MacBook-Pro.local wirelessproxd[80]: Failed to start advertising (Unknown error.) for identityservicesd Jun 20 06:55:27 Gowthamans-MacBook-Pro.local sharingd[278]: 06:55:27.354 : SDActivityAdvertiser::continuity:didFailToStartAdvertisingOfType:withError: Activity (The operation couldn’t be completed. (com.apple.identityservices.error error 200.)) – Gowth Jun 20 '16 at 17:33
  • That comment should be an edit to the question and I still don't understand don_clean option - I can understand delete .DS_Store so I must assume that is different – Mark Jun 20 '16 at 17:56
2

In a Terminal:

grep "I/O error" /var/log/system.log

This will output to the Terminal all lines in the system.log file that has I/O error in it. Output such as kernel[0]: disk0s2: I/O errors are indicative of a falling and or damaged HDD. Note disk0s2 is an example and depending on which disk and partition has bad sectors the disk number and slice number will be different then the example. If you have output such as this and aren't backed up then do it before doing anything else!

Note; Depending on when the last time you had an error copying something it may not be in the current system.log file and you'll ether need to check the archived system logs or grep directly after the copy error.

If the copy is failing just on a particular file, you can attempt a recovery using ddrescue on the target file to try and copy it. ddrescue is a third-party utility that will need to be installed however dd is a part of OS X and it too can be used, although ddrescue offers more control and options then dd does.

  • Thanks a lot for your response. Let me check on this and get back to you :) – Gowth Jun 20 '16 at 7:00

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.