After having upgraded to OS X Lion seamlessly, the whole system became unresponsive. Sometimes, I have to wait seconds for keypresses or clicks to have effect, even sound playback or the Dock animation stutters, while strangely the CPU usage remains low. Repairing my disk and its permissions didn't help, upgrading to 10.7.1 neither. Can somebody help?

FYI: I have a 2.3 GHz 13'' MBP with 4 GB RAM.

  • Can you give more details on your system? What Mac do you have, how much ram, etc? – cftarnas Sep 6 '11 at 18:39

This kind of thing is a RAM problem 9 times out of 10. Your RAM is constantly being paged in and out to your (relatively slow) hard drive, causing you to wait. THe best solution is to upgrade your RAM or if it's already maxed, consider getting an SSD.

  • +1 - this can often be a RAM issue. @thSoft: Does the problem start at boot or after using it for a while? – cftarnas Sep 6 '11 at 21:51
  • I've got the same issue on an i7 2.8GHz iMac with 8GB of ram and a SSD drive with plenty of free space. My wife also has an issue with MBP with 2.4GHz Dual Core with 4GB of RAM. I have found that Safari gets slower as the WebProcess process grows in size. Restarting Safari frees up the memory that process uses (effectively.) – Greg Cain Sep 7 '11 at 0:50
  • Continue your regular usage but try the "purge" command in terminal when things slow down and see if it helps. it'll delete unused memory caches which will slow relative processes but will at least make the machine useable – Alexander Sep 7 '11 at 2:24
  • This occurs not immediately at boot but only shortly thereafter. Indeed there are huge peaks in write pagings in the unresponsive periods (even though I have free RAM remaining). So my recent configuration isn't really qualified for Lion. :S – thSoft Sep 9 '11 at 0:25
  • @XAleXOwnZX Unfortunately, it doesn't help either. – thSoft Sep 9 '11 at 0:28

I have a 2.16 GHz Core 2 Duo iMac that recently had this problem (I suspect it was caused by too many windows open under Safari) and I had searched on this site for a possible fix. Nothing I tried worked, so I unplugged the iMac and planned on taking it in for a repair. I got to thinking about the possibility that the mac's internal battery may be preserving the condition, preventing me from recovering from the freeze. After having the Mac off the mains for 24 hours, I re-plugged it and fired it up and the freeze was gone. I don't know if this was just dumb luck, but I don't have the freeze anymore.


The thing is moving from Snow Leopard to Lion should not have caused a slow-down. Period. If it was running fine on SL, it should run fine on Lion. The only reason Lion would be slow in this case is if something else/new was added and is in use with Lion, or if your hard drive is now short on space.

If nothing else changed other than installing Lion, then that is where you want to spend your efforts to fix.

I would first try Repair Permissions with Disk Utility. I always do that with a new Os that was installed on top of an old one. Usually I get a one-time repair of a bunch of items.

Test to see if the problem went away.

Next I would try a Safe Boot, and then just restart normally instead of logging in.

Test to see if the problem went away.

Please report back here with whatever you did, and post the results.

Hope this helps.

  • I should add that it is indeed possible that RAM is a cause, but that should have not changed just by going to a new OS. It would be coincidence if a stick of RAM failed when you installed Lion. – modelamac Sep 6 '11 at 22:19
  • I have noticed that my standard OS RAM footprint seems a bit higher after moving to Lion. Mail and MDS seem to take more RAM than they did in Snow Leopard. If the difference is enough to push the computer to swap it could be quite noticeable. – cftarnas Sep 7 '11 at 0:48
  • A quick fix may be to turn off Spotlight temporarily. It's very aggressive about indexing in Lion. It may be that simple. – modelamac Sep 7 '11 at 1:00
  • Unfortunately, as I mentioned, repairing disk permissions didn't help. – thSoft Sep 9 '11 at 0:23

You can try reseting the System Management Controller (SMC) - as described in this Apple Support article.

  • Thanks, I tried that also, and it didn't help. – thSoft Sep 27 '11 at 21:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .