I have been trying to find an answer to this online, and the closest I have come is this question: Very long login times in Mac OS X. It does, however, not replicate my issue exactly.

My Mac (OS X, El Capitan, 10.11.5) spends a very long time (approximately a minute) whenever I try to log in. This is a fairly recent development I have noticed over the past ~month -- before that, log in times were of the order of a second. As a research student who has to run in between different rooms with my laptop all the time, having to wait for it to log on for so long each time I close down the screen gets really frustrating. I could, of course, try to change the settings for the laptop to not go to sleep each time the screen closes, but that does not address the issue.

I have noticed that if I turn the WiFi off, the log in process is far shorter; I am logged in within one or two seconds after typing in my password, just like it always used to be before. Again, I could, of course, turn off the WiFi each time my computer will be going to sleep, but that, again, does not address the issue. I am in need of using WiFi, and dealing with turning it on and off all the time is extremely annoying.

Based on the research I have tried to do on this, it sounds like this has to do with some active directory settings, but this is something I am unfamiliar with. Can anyone tell me whether I am on the right track, or maybe tell me what my solution to getting constantly short log in times is?

  • @klanomath Any chance you can tell me how to find out which ones my computer is set up with? The university set up the computer for me, and I'm not sure about the details. I suspect I have a local account (user created on computer), maybe with the possibility of a network account. I'm not familiar with directory services. – nataliaeire Jun 18 '16 at 10:34
  • @klanomath The command for local data gives me an enormous amount of output including my details, which I take to confirm that I have a local account, but I'm uncertain as to what more to read out of it. The AD data command tells me 'Data source (/Active Directory/domain/All Domains) is not valid.' Does that mean that there is something wrong with the command (that I'm searching the wrong place), that I don't have AD, or something else? – nataliaeire Jun 18 '16 at 11:13
  • @klanomath Any chance you are able to help me out with this, or tell me how to proceed? (I apologise if leaving a new comment is considered rude; I'm not sure how things work here, and also a tad desperate!) – nataliaeire Jun 19 '16 at 13:35
  • @klanomath Thank you for clearing that up! Unfortunately I cannot figure out what the domain is. I have tried all likely combinations I can think of. Does that mean I am stuck, and cannot resolve this issue? – nataliaeire Jun 19 '16 at 18:14
  • @klanomath I'm not entirely sure what you're asking, but I do have my own directories on the network here and there, and I often ssh myself into various places when working from home. Is that related to your question? I tried using the domains I know of based on my knowledge of directories, but none of them worked with dscl -u NTID -p /Active\ Directory/domain/All\ Domains -read /Users/your_username. – nataliaeire Jun 19 '16 at 19:19

You must log in to answer this question.

Browse other questions tagged .