1

I have a Macbook Pro 15 inch 2009 running OS X 10.10.2. I want to update the OS to El Capitan but the App Store won't open - nor will Safari, Contact, Calendars etc. Chrome seems to be one of a handful of the apps that are opening fortunately.

I've already tried the following:

1 - Opened Library/Preferences/com.apple.appstore.plist and deleted it

2 - As above but for Safari because apparently Safari, App Store and iTunes share the same history and preferences?

3 - Created another user but encountered the exact same problem.

4 - Tried running this command on iTerm (because Terminal wouldn't run either)

softwareupdate -a -i

but this failed because I don't have the correct permissions. On this one I was logged in as an Admin and also tried starting a bash command with sudo -s but it didn't output anything.

5 - I attempted to start Mac OS Recovery but holding cmd+r on startup but it's asking for a password but none of the passwords for any of the admin accounts work.

What else can I possibly try short of ordering recovery disks or saying screw it and buying a new Macbook altogether (which I really don't want to do!)

Thanks

1

When you restart a Mac holding command R or just option to choose a different os, that indicates a firmware password lock is present.

After reading the above, you might need a repair to regain control to wipe and reinstall or just boot to a working OS. Since your Mac is outside normal support by Apple, you might need to change the hardware yourself - perhaps removing one RAM stick per these threads:

Once that's done, you can boot to Recovery HD and reinstall the OS or erase the drive as needed.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .