0

A couple of days ago, I closed the lid on my 2012 MBP running El Capitan with Samsung Pro 830; it had nearly no power left. Power ran out while I was closing the lid, I suspect, so I plugged it in, and it wouldn't come back up. So I powered it on. It wouldn't then boot.

Tried NVRAM and SMC resets; no success.

Startup key combos:
Tried starting up in safe mode; no success.
Tried startup manager; no success.
Tried Diagnostics; no problem reported.
Tried Single user mode; no success.
Tried verbose mode - got EFI error.

Swapped in another disk to try and restore from an SL DVD from my older MBP; no success (apparently you can't install an older version of OSX than that it shipped with).
Put knackered disk back in, tried System Restore - success! This got me into Disk Util for ML (original OS for the 2012 MBP) where I could repair the disk. Diskutil found some problems with the EFI, and it booted into My ElCap OS, everything seemed ok. Ran diskutil again for good measure, no problems reported.

I turned it off so that I could secure the hard disk and the bottom cover of the machine.

It then wouldn't boot again.

I then tried internet recovery and got an error with an exclamation mark over the little globe on the restore screen with an error 'apple.com/support: -2105F'

This was now a little beyond me, and Google wasn't helping, so I phoned Apple. They suggested that I try a new disk, as mine was completely bajanxed.

So then I got my 2010 MBP (also running ElCap) and downloaded the 'Install El Cap' program from App store with a view to creating a local boot USB drive to attempt recovery.

I have borrowed a (120Gb) SSD from work, formatted with a GUID partition type and OSX journaled FS, and plugged in and booted from USB drive.

The install process nearly completes and then fails, not really giving me any error info.

Tried this a few times, same results, reformatting new SSD on second MBP, also via USB El Cap Diskutils. No problems showing on the new SSD.

Internet restore also fails on new SSD (with the same '-2105F' error.)

The only thing I've got going for me right now is that I managed to mount the broken boot disk onto my 2010 MBP and decrypt the volume, figuring that one less obstacle can only help (took 8 1/2 hours, but completed successfully!). I can read the files on this drive, so I haven't lost data per se. Once decrypt was done, I ran repair_packages from terminal on 2010 MBP on the mounted (broken boot) disk - it found some errors and repaired them. fsk_hfs also completed fine with green lights.

The last attempt at El Cap install completed successfully (tried whilst writing this), and it restarted - white screen, with the no entry symbol. The strange thing was that I didn't get the 'traditional' pop up with the 4 choices when trying to install ElCap, just went straight into install.

Wondering whether there was a setting saved somewhere, have now reset NVRAM and SMC again, and trying install. The pop-up menu has now appeared, and am trying again.

Has anyone got any suggestions, as I'm running low. I'm starting to wonder as to whether I've got a hardware problem.

Latest attempt has also failed - 'An error occurred while updating system extension information'.

Edit: So have now successfully installed another copy of ElCap connected via an external drive from my 2010 MBP. It booted fine. I then put the hard disk into the 2012 MBP, and...nothing. So I hooked it externally from the 2012 machine, and it booted. Put my old hard disk (that started the problems) into the external hard disk cradle, and the 2012 machine booted. So I guess it's a hardware issue. AppleCare ran out 6 months ago :(

Edit2: Just to confirm, it was the cable that was the problem. New one fixed the issue.

  • Take it to an Apple Store and have it professionally diagnosed. – user3439894 Jun 16 '16 at 12:20
  • 1
    Though I can't follow all the steps taken I'd suspect the internal SATA-cable to be fried/broken. – klanomath Jun 16 '16 at 13:43
  • TL;DR. Try Apple Hardware Test (AHT) to rule out any hardware issues. – Allan Jun 16 '16 at 14:08
  • Hi Allan, thanks for reply. I've since tried that too. It tries to diagnose from the internet, again I get the little exclamation mark superimposed over the globe, but a different numerical error. I think it is '-3000D' but can't remember. I'm taking it to a local Authorised Apple place (as suggested by Apple support) and although my Applecare has run out, apparently it may be covered by a UK 6 year consumer protection thing that Apple subscribe to. I just need to provide proof of purchase (which I have). @klanomath I hope it is. I can't see any damage on it, but you never know. – FiddleDeDee Jun 16 '16 at 14:41
  • @Ian Usually you can't detect a broken cable with your eyes because the structures are so fragile. Your Mac (but especially the MBP 2010) is known to have a "sensitive" SATA-cable. – klanomath Jun 16 '16 at 14:47
0

Further to @Allan's advice and @klanomath's help, the fix for the issue was to replace the Hard Disk cable.

-1

MBP early 2011 model w/ SSD, Mavericks OS.

Allowing shutdown due to out of battery power, I had this twice, with different fixes:

  • SSD was trashed, un-recoverable. Replaced SSD, restored my backup. Back to normal. I fixed it myself; re: iFixit.com repair manifesto

  • Booting from backup would not complete startup (or appeared not to). Cause: Bad video card. My local repair guy said Apple knows this era MBP has defective video cards.

    • P.S. Turns out the SSD in this case was OK but now I have a more capacious SSD.
    • P.S. The repair guy surmised this in about 30 seconds simply by watching the screen as the machine started; the problem is so relatively common.
  • The 2011 MBP video problems are handled by Apple free of charge apple.com/support/macbookpro-videoissues Additionally, if your "repair guy's" diagnosis was limited to watching the video and not running a board level diagnostic tool, he was guessing. – Allan Jun 16 '16 at 14:15
  • Was there a time limit on the freebe? My repair was done March 2016. – radarbob Jun 16 '16 at 14:18
  • From the website I linked: The program covers affected MacBook Pro models until December 31, 2016 or four years from its original date of sale, whichever provides longer coverage for you. – Allan Jun 16 '16 at 14:19
  • Huh. Oh well. Livin' learn. And, it was an educated guess, I guess. He pointed out the color and line manifestations as indicative. In any case that was a good fix. As for his original apparent prevarication I'll just have confront him and make any appropriate review of that business (which is otherwise very highly rated). – radarbob Jun 16 '16 at 14:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .