8

Would it work if I run Siri on OS X El Capitan by copying Siri.app from macOS Sierra to the OS X El Capitan?

Just want to find out what exactly would happen even though OS X El Capitan doesn't support Siri.

  • 2
    This is a good question, +1 from me - even if something isn't practical - asking why you can't back-port an app helps people learn how things work. – bmike Aug 12 '16 at 23:21
  • @bmike Thanks! I thought this was quite interesting, so I tried it out and decided to share it with the community – Panda Aug 13 '16 at 0:20
10

No, it won't work.

The app will show a prohibitory sign over the app icon.

Image 1

When opening the App, it will show an error message.

Image 2

Even if you managed to hack/crack/disable the check that prevents the Siri interface app from running, the parts of the system behind the scenes that actually run Siri on macOS, communicate to the network and process the speech recognition are missing on El Capitan.

So if the door on the second floor is locked shut because the deck hasn't been built yet - you can cut the lock and eagerly exit the door, but you'll promptly fall to the ground since the deck isn't built into El Capitan yet.

  • Just for fun, what happens when you navigate to Siri/Contents/MacOS and execute the Unix executable there? – JMY1000 Aug 12 '16 at 20:25
  • @JMY1000 I've edited this to explain that the plumbing for the siri app to do any work is missing as well on El Capitan. The app is but one of several interconnected parts. – bmike Aug 12 '16 at 23:20
  • @bmike Thanks. I was just curious as a few apps I've managed to get to work on newer (not older generally though) versions of OS X that usually refused to launch. – JMY1000 Aug 13 '16 at 0:02
2

I think the only way is upgrade to Sierra Beta.

  • 1
    That's just a thought. New innovation could make it possible. Think Different. – Shritam Bhowmick Aug 12 '16 at 20:15
0

Yes, you might, providing the following:

  1. You have booted OS X El Capitan 10.11.6
  2. You have a working start up disk with macOS Sierra 10.12 mounted to your El Capitan boot-up.

At least that was what happened, by chance, to me, when I checked differences between the two operating systems. It could be that Apple deliberately excludes Siri from El Capitan. Perhaps not on technical grounds, though.

0

Sorry about being late here, but yes, you likely can. Find Siri.app, open it's info.plist file, and change the LSMinimumSystemVersion from 10.12 to 10.11. I'm going to look into what Siri.app requires to run, because this interests me, but if it won't open, please try running /Applications/Siri.app/Contents/MacOS/Siri in terminal, and tell me what the error message is.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .