0

I have 6 instances of httpd running, and they respawn after I kill them. I tried the solution provided on this answer ,

$ pgrep -fl foo
40679 bash /tmp/foo
$ launchctl list|grep 40679
40679   -   com.example.foo

in my case, sudo pgrep -fl httpd to find out what process is creating them and got this as a result:

83071 /usr/sbin/httpd -D FOREGROUND -f /Library/Server/Web/Config/Proxy/apache_serviceproxy.conf -E /private/var/log/apache2/service_proxy_error.log

and six more instances that according to my Activity Monitor depend on the first one. Then I entered sudo launchctl list|grep 83071

and got this 83071 0 com.apple.serviceproxy which I guess is the process / file / service that is launching this instances, but I cannot find it anywhere.

I also tried launching and then killing Apache as per this question, but that just created another instance of httpd.

Excuse my utter ignorance on the CLI, just trying to find out how to kill those httpd instances that are using the 8443 port to listen and conflict with another service I'm trying to install.

  • I guess you have OS X Server installed, and it's using port 8443 for secure caldav connections (Calendar server). While possible solutions have been suggested elsewhere, it stands to reason that with every new OS X Server update, the default settings (using 8443) will be restored. Would it possible to configure your service to not use 8443? – Asmus Jun 15 '16 at 21:58
  • I do have OS X Server installed, but the Calendar server is off. Actually I turned off all services to check if the instances would disappear, but they didn't. I think I can move the Unifi controller to another port. Would the problem disappear if I uninstalled OS X Server? – Jaime Santa Cruz Jun 15 '16 at 23:27
  • 1
    I guess you could uninstall OS X Server, but maybe changing the Unifi settings is the better solution in the long term (if you want to use OS X Server). As far as I know, OS X Server now claims these ports to "have" them when needed, even if the service (caldav, http, …) is not active, and this is probably not going to change soon. – Asmus Jun 16 '16 at 18:15

You must log in to answer this question.

Browse other questions tagged .