0

I have MBP Late 2013 and El Capitan 10.11.4 installed. But i have got a serious WiFi Connection dropping problem for a while. It is quite irritating as you may guess.

I couldn't find any clue why this is happening. None of my other devices experience the same problem, only MacBook Pro.

Here is the console logs http://pastebin.com/fY3J5PUW

Thanks in advance

1

This fixed it for me:

  1. System Preferences – Energy Saver – Battery Power : Uncheck “wake for network access”

  2. System Preferences – Network – Advance – TCP/IP : Configure IPv6 – Switch to “Link-Local only”

Found that above fix in the comments of this article http://osxdaily.com/2015/10/16/fix-wi-fi-problems-mac-os-x-el-capitan/

  • Actually setting wifi connection protocol to a fixed value (for example 802.11n) was helped me. – bahadir arslan Aug 4 '16 at 5:11
  • @bahadirarslan Glad to hear you got it working. Where can I set the wifi connection protocol? – Jack Aug 4 '16 at 17:54
  • i configured it at router settings. – bahadir arslan Aug 4 '16 at 17:59
  • Ahh, was thinking it wasn't a mac setting!.Will try that if I have any issues in the future. – Jack Aug 4 '16 at 21:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .