1

Not sure if this is the right forum to ask this question. The computer in question is a Mac Book Pro (10.9.5, aka Mavericks).

There is a site that in Chrome that repeatedly comes up with its "Aw, Snap" page. It's really bothering my co-workers that it's loading up fine in other browsers but not in Chrome repeatedly.

So, I've been trying to figure out the answer. I came across the issue of dns cache maybe?

Since the dns command is different based on OS version, I've tried dscacheutil -flushcache;sudo killall -HUP mDNSResponder to no avail.

Wanted to see if it was working, so tried:

sudo discoveryutil mdnsflushcache

sudo discoveryutil udnsflushcaches

And all I get from those are:

sudo discoveryutil mdnsflushcache

How do I make my dns flush work, and how will I know it worked? And could there be any particular reason why a site won't repeatedly load up in Chrome unless you hit refresh multiple times?

EDIT

Editing to add that I've literally done everything under the sun on Chrome, ie, clear its cache, remove cookies, and reset it repeatedly.

And still the site repeatedly comes up with its "Aw, Snap" page.

  • @klanomath, really? I didn't know that. What would be the correct ones? Believe me, I've repeatedly googled it ... and until your comment, I didn't know that Mavericks didn't use discoveryutil ... – user273072545345 Jun 14 '16 at 20:21
  • @klanomath, I did actually get command not found. Which I wasn't thinking of when I replied to your comment earlier. Sorry. Just tried your commands in one sweep first time, and this is what I got: killall: unknown signal flushcache,; valid signals: HUP INT QUIT ILL TRAP ABRT EMT FPE KILL BUS SEGV SYS PIPE ALRM TERM URG STOP TSTP CONT CHLD TTIN TTOU IO XCPU XFSZ VTALRM PROF WINCH INFO USR1 USR2 – user273072545345 Jun 14 '16 at 20:40
  • @klanomath, then I tried doing it one by one ... and it doesn't give any feedback ... is it supposed to? There's no output ... etc .. – user273072545345 Jun 14 '16 at 20:41
  • None of the commands yield anything in Terminal.app if executed successfully (=without errors). The command sudo killall -INFO mDNSResponder creates about 300 lines of output in the system.log file. Use Console.app to open this one! There is a space between -INFO or -HUP and mDNSResponder! – klanomath Jun 14 '16 at 20:44
  • @klanomath, how do I use the terminal to open the output? By Console.app, you meant terminal, right? – user273072545345 Jun 14 '16 at 20:50
1

It sounds to me as though the problem is with Chrome itself since you said that the site works fine in other browsers.

When you visit a webpage (like a search results page), Google Chrome will pre-fetch the IP addresses of all websites that are listed on that page. Since the browser has the IP addresses of all the links in advance, DNS pre-fetching ensures that any links that may you click on that webpage will load faster. However, when pre-fetching fails, something that’s not very uncommon, you may get the “link broken” error. (source)

To disable the pre-fetching, go to Tools > Options (or Preferences on a Mac) > Under the Hood and uncheck the setting that says “Use DNS pre-fetching to improve page load performance.”

Otherwise you can also try simply clearing the cache of that specific site.

  • Hey, thanks for replying. Unfortunately, the answer is applicable to the older version since the article is from 2012, and when I checked into the Privacy settings in Chrome to uncheck the DNS pre-fetching, it's not there. The version of my Chrome is: Version 51.0.2704.84 (64-bit) – user273072545345 Jun 14 '16 at 20:35
  • also, I added an edit to my post in regards to cache clearing, etc ... – user273072545345 Jun 14 '16 at 20:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .