0

My phone was replaced yesterday, and I've since been trying to restore it from the backup I made just before it was replaced.

I have no greyed out apps, and all my photos are back, but it says I can't install the newest iOS update or make a backup to iCloud because it's still restoring from the iCloud backup.

I've turned it off and on again, turned wifi off and on again, put it in Airplane mode and switched that off, and also tried resetting it. It's asked me for my Apple account password a few times but then I haven't seen anything change after I've entered it, and there's no spinning wheel in the top header bar to show that anything is downloading.

Any ideas as to what else I can do to try and resolve this please?

  • Did you tried to do a complete factory reset? Go to Settings > General > Reset . – rwzdoorn Jun 14 '16 at 10:29
1

Three things come to mind one have you tried resetting doing a hard reset by holding home button and the power off button till the apple logo comes up and says to connect to iTunes then connect to iTunes and restore another couple of lil tricks are hold the power button till it brings up slide to power of instead of powering off ur phone hold down the home button this will wipe all back loading apps another thing is go to App Store and after the App Store loads up hit the explor button 10 times if none of this works got me but my mothers phone did the same thing and by doing these things a few times it is now working not sure tho

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .