0

I have removed the Transmit app (ftp program) by drag and drop it to my trash including the other files of the application in the Library folder ~/Library and empty the trash.

Then I found out that there is a file was not thrown away, which is 'com.panic.transmit.sfl'. I tried to delete this file to, but when I want to drag it to the trash, the trash will be changing to an eject arrow icon.

When I double click the file, I have to options: delete alias - this doesn't do anything - or recover alias - that will open a dialog where you can select a file - but I don't know which file should connected to it.

Also the file doesn't have a path, but when I search in ~/Library for transmit the file appears in the finder.

I try to download and install Transmit again. Than there is also a new 'com.panic.transmit.sfl' file created, tha can be deleted, but still the other one is visible.

Is there a way to delete undeletable files?

enter image description here Doubble click the icon will give to options, described above

  • 1
    It's working. I notice that I doesn't add Macintosh HD to the list. The instructions below are working. @patrix – Caspert Jun 12 '16 at 15:20
2

First thing to try in these cases is to remove it via Terminal:

  • Open Terminal
  • Type rm followed by a space
  • Drag the file into the Terminal window (wait for the green + sign to appear, then release the mouse button) -> Path to file should get added in the Terminal window
  • Press Enter

Based on your additional information it seems to be phantom file only "known" to Spotlight. To rebuild the Spotlight index, either see Apple's support article on the topic or run

sudo mdutil -E /Volumes/Macintosh\ HD

in Terminal.

  • Not working. I'm not able to drag the file. When I will drag it, the trash immediately changes in an eject arrow. Also tried to rename it, but that's not allowed.. The path is also not shown in the finder. I am only be able to double click it and recover the alias or delete the alias. Last one doesn't work and the first one, I don't know which file I should find than.. – Caspert Jun 12 '16 at 10:08
0

Are you dragging to the Terminal window Caspert, or the trash? I don't have the reputation to reply to patrix's comment but you could also rm the full filename while inside the directory, eg.

cd /Library/path_to_file_you_want_to_delete
rm file_you_want_to_delete
  • I tried both, but aren't able to drag it in the trash or terminal. The problem is that the file doesn't have a path... When I install the program again, the file is located in /Library/Application Support/com.apple.sharedfilelist/com.apple.LSSharedFileList.ApplicationRecentDocuments but only the new installed version will add the file to that folder. That file I can delete and edit etc.. If there is a way to know the alias of that file, than I can fix the alias of the other file I think. Or is there another way to delete undeletable files? – Caspert Jun 12 '16 at 11:53
  • If I search for the file in finder, I must select Library for the search area, otherwise the file isn't located. – Caspert Jun 12 '16 at 11:57
  • Can you enter into a terminal window: sudo find / -name com.panic.transmit.sfl and post the output? – Scottmeup Jun 12 '16 at 14:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .