I am running Ubuntu in Virtualbox in Mac OS.

I found that rightclick in the guest Ubuntu, by tapping the trackpad while pressing ctrl key, doesn't work. E.G.

  • it doesn't show the menu for file properties and removal option, when right clicking a file under Nautilus.

  • in chrome browser, when right clicking a link, it doesn't show option to open it in a new tab.

when I connect a wired mouse to macbook pro, right clicking works i.e. brings out properties of a file, etc. So does two-finger tapping the trackpad.

How can I troubleshoot this?

  • How did you configure your mouse in Virtual Box? Can you post a screen shot? – Allan Jun 10 '16 at 22:05
  • In virtualbox, "Input -> Mouse Integration" is checked. Other than that, I don't know what to take screenshot of. – Tim Jun 10 '16 at 22:18
  • Under System > Pointing Device, what do you have selected? – Allan Jun 10 '16 at 23:18
  • USB Tablet. Oh, sorry, I am using touchpad rather than mouse. So the problem actually happens when I click the right bottom of the touchpad which is similar to clicking the right buttom of the mouse. – Tim Jun 10 '16 at 23:50
  • 1
    A couple of things: To diagnose it, you should use a basic wired mouse. Secondly, have you installed Guest Additions in the Ubuntu guest VM? – Allan Jun 12 '16 at 15:15

When ever I'm setting up a guest OS, I find it helpful to do two things.

  1. Open up the OS X system preferences and review every setting on every tab of the mouse and trackpad, paying particular attention to multi button and multitouch gestures and shortcuts.
  2. If you use a trackpad or touch device, connected multibutton mouse over USB to make sure that those settings are passed along to recognized

At that point, you will want to be sure any guest OS additions are loaded in the guest VM. That will make the guest most likely to receive the best input and have drivers on the ubuntu os configured to take advantage of the multi touch / right click events. You can always check the virtual box support forums once you have a specific set of OS versions - you might uncover a bug in the code or they decided to program things as they work intentionally.

  • I have added that the problem happens when I tap the trackpad while pressing the ctrl key. It doesn't happen when I connect a wired mouse to my macbook pro. – Tim Jun 12 '16 at 15:33

I was able to activate the right click menu in Ubuntu 19.04 running on Virtualbox 6.0.6 on MacBook 2019 with macOS Mojave 10.14.4 using the following key command:

Control + Option + Click

This worked with both left and right Control + Option keys, and worked on external keyboard with external mouse as well as the Trackpad on my MacBook Pro.

Please comment, and confirm my findings. I was personally worried about this as it made working with the Trackpad very difficult on MacBook, and I thought I was always going to have to carry a mouse with my laptop, because I prefer to develop my programs/websites in Ubuntu.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .