1

For some reason my Mac's keyboard has changed fro British English to US English. This means that when I need to do a "£" sign I need to hit option+3 rather than shift+3, which is pretty irritating.

I know that if I go into System Preferences > Keyboard > Input Sources I can add a British English keyboard and then switch to it. But how do I then set that British English keyboard as default and delete the US English keyboard? When I select the US English keyboard in the list of keyboards, the "-" symbol at the bottom of the list is greyed out: see screenshot below.

Keyboard preferences panel, with "-" greyed out so I can't remove the US keyboard

  • You select the keyboard layout via the Input Source menu at the top menu bar of the screen (you should see a British flag). Once chosen, it should stick until you change it again. – Dictionarics Anonymous Jun 10 '16 at 21:18
  • Thanks! I'm already aware of that, though; what I want to do is delete the US English keyboard so I only have the British English keyboard. – Jim Jun 10 '16 at 21:20
  • It's a little obscure tbh. It might help if you post a screen shot of the Preference panel you are having problems with. – Dictionarics Anonymous Jun 10 '16 at 21:39
  • Thank you -- I've added a screenshot above, showing the greyed out "–" symbol at the bottom of of the list of keyboard languages. – Jim Jun 10 '16 at 21:42
  • It appears to me like something is wrong internally. There is an answer somewhere else that suggest deleting specific preference file to reset the language settings (some other settings will also be lost): Go to the folder ~/Library/Preferences/ByHost and delete all files named "com.apple.HIToolbox". Then restart the Mac and try if configuring the list of input sources works now. – Dictionarics Anonymous Jun 10 '16 at 22:03

You must log in to answer this question.

Browse other questions tagged .