1

I have a work iPhone 6 that I just updated the latest software, and didn't realize that entering my personal iCloud information would result in receiving SMS's being sent to both personal iPhone 5S and work iPhone 6. I removed the iCloud and created a new iCloud account, and now get some SMS's from other people, and not all SMS's sent or receieved are showing up on the work iPhone 6. How do I remove my work iPhone 6 from the iCloud so it doesn't continue to show sent and received messages from my personal iPhone 5S? (Maybe the SMS's still appearing on both are from other iPhone users?)

  • Go into the Settings app then into iCloud settings on both phones and make sure that the accounts aren't the same. Then comment back @JohnRamos with what you find. – owlswipe Jun 10 '16 at 18:25
2

To remove your work iPhone 6 from your personal iCloud account, go to Settings, select iCloud, scroll down to the very bottom, then tap Sign Out.

To disable iMessage on the work iPhone without removing it from iCloud, go to Settings, select Messages, and uncheck the iMessage option.

If you're receiving weird, spammy iMessages, scroll down to the Send & Receive option of the Messages section, select that option, and check/uncheck the addresses you'd like to receive iMessages from. iMessages can be sent to email addresses, so if you have a public-facing email or one that's shared often, you might want to uncheck that address.

If you're not receiving text messages even after disabling iMessages, you may wish to use Apple's Deregister iMessage page; it's intended for people who are switching from an iOS device to a non-iOS device, and thus wish to disable iMessages.

Another tip: Make sure that the people whose messages you're not receiving aren't attempting to send iMessages to your personal iMessage account! Make sure to give them your work phone number, and text them from your work phone; otherwise, they may have created a contact with your personal iCloud account as the iMessage address.

0

You should be able to do what you want while still using your iCloud account on the work phone for apps, music, reminders, FaceTime, and other things, if you want. You can choose which things are sync'd and turned on on the work phone.

On your iPhone 5s, go to Settings > Messages and see to it that it's not forwarding SMS under Text Message Forwarding. This will stop SMS messages to your personal number from going to the work phone. Also, on the work iPhone, go to Settings > Messages and turn off iMessage. This will stop people with Apple devices who send your iCloud account messages from having those messages go to your work phone.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .