8

I've got an iPhone 4 (running iOS 4.3.5) and iTunes (v10.4.1) on a Mac running OS X (10.6.8).

When connected to iTunes, I've got the Music -> Sync Music -> Include voice memos option unchecked, but that seems to have no effect. Each time I sync the phone, all the new voice memos are pulled down to iTunes and dropped in my library.

So, the question is: How can I prevent iTunes from pulling down the voice memos and just leave them on my iPhone?

  • Still a problem as of iOS 8. – duozmo Sep 6 '15 at 21:51
  • I'm still having this problem. Any updates? – Vivek Subramanian Oct 7 '17 at 3:09
  • 1
    @VivekSubramanian - I stopped trying to get this to work and just switched to using other apps for voice memos. My current favorite is "Just Press Record". (I've updated my answer with that note as well) – Alan W. Smith Oct 8 '17 at 11:31
3

Currently, there doesn't seem to be a way to prevent iTunes from pulling in the voice memos. The closest I've been able to figure would be to have a script or launchd item that simply removes anything that it sees. Preferable copying them to another directory for storage.

Update: October, 2017

I've switched to using Just Press Record which is dedicated to voice memos. It's fast to start and also creates transcripts. They're pretty good most of the time, but sometimes they get pretty far off. It's a nice feature, regardless.

The app costs a few bucks, but it's well worth it. (And, I like to support developers so they can keep working on software I like.)

1

I figured out: You have to MARK "include music videos" and not mark "Include voice memos". It´s strange, since what I wanted had nothing to do with music videos. If you not mark "include music videos" it doesn't work.

  • 2
    Unfortunately, that isn't working for me. I tried with both with it checked and with it unchecked. In both cases, it still pulled them down. – Alan W. Smith Sep 14 '11 at 20:22
1

It's not that weird. It does it for me too on 4 different Macs in my home. The Apple Support Discussion site contains statements by many others experiencing the same thing. I don't know if it's a bug in iTunes, the voice memo app, or what. Just be careful. If your sharing your music library on a network you're also sharing those voice memos with everyone on the network since they're in your music library.

Wish Apple would create a separate category for Voice Memos in iTunes and get them out of the music library. And they need to fix this syncing issue. I've written feedback submissions about this. I encourage others to do the same.

1

My solution is not perfect, but it is better than hearing some private voice memo when the music library is played among people... It is also better than having to remember to delete them all the time.

The solution is the following: 1) go to "/Users/yourusername/Music/iTunes/iTunes Media" 2) right click on the "Voice Memos" folder and select "Info" 3) in the "General Properties" section select "Locked"

That's it. This prevents all apps from accessing the Voice Memos folder. This also means that iTunes cannot copy voice memos to that place.

There is only one slight inconvinience with this solution, however. When trying to synchronize new voice memo iTunes shows an alert complaining that it was unable to access the disc. But this only happens during the first synchronization after new memos have been added. Until You add new memos, the alert box will not appear. So I would say this is only a slight inconvenience compared to necessity of remembering that memos have been added and deleting them. Or listening to Your private memos being played to people listening to Your music...

Source: http://forums.macrumors.com/threads/apple-come-on-voice-memos-in-itunes.1533972/

  • I’ve been using this technique successfully for years (thank you), but as of iTunes 12.9 (bundled with Mojave), I get error -54 on every sync. Unlocking the Voice Memos folder fixes that problem. Unfortunately iTunes still doesn’t respect unchecking “Include voice memos.” – duozmo Nov 19 '18 at 1:19
0

First, select all voice memos in your library. Then right click on the selected multiple items and open 'Get Info'. Open the 'Options' tab and select Media Kind as 'Voice Memo' and keep the box checked. Close it. Then, unckeck 'include voice memos' from the Music section on the iPhone in iTunes. Now sync your iPhone without including voice memos !

  • 1
    This addresses the syncing in the other direction. – duozmo Sep 6 '15 at 21:44
0

Did you try looking on the device's "Music" tab?

enter image description here

  • 2
    I must not have made that clear in my question. I've got that unchecked already. It's still pulling down the Voice Memos. Does that setting work for you and prevent them from being downloaded? – Alan W. Smith Sep 5 '11 at 23:05
  • yeah works fine, are you sure it's still actively syncing or the files on your computer were just left over from before? Toggling the option above doesn't delete voice memos already synced to your iTunes – Alexander - Reinstate Monica Sep 6 '11 at 1:08
  • 1
    It may just be something weird in my machine, but it continues to pull down new voice memos. I've deleted them all on both the iPhone and iTunes and toggled the setting back and forth. New iPhone voice memos still sync to iTunes even when the setting is off. (I also deleted the "Voice Memos" playlist in case that was related, but those tests didn't work either.) If it's working for others then it must be something weird that I've got on my machine. – Alan W. Smith Oct 14 '11 at 2:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .