EDIT: managed to reformat the partition to JHFS+, after accidentaly creating another partition i merged the new and the old one i dint want, then it let me merge all of them together.

I created a partition to originally use for linux. I gave it 30 GB and installed Linux no problem. Now I am in need for space in El Capitan and I can not remove the partition to give me more space. I managed to reformat it to HFS+ and it is not a corestorage(?) unit.

Here are screenshots of Disk Utility and the output of diskutil list:

Disk utility

Terminal with Diskutil list

  • 1
    If you solved the problem, you should add it as an answer which you can then "select" as the solution. Please refrain from adding "SOLVED" to you post since that defeats the purpose of the system here on AD. – Allan Jun 10 '16 at 16:41

It is because the Linux file system is something that OS X cannot natively read. The easiest thing to do is to is load up a live Linux CD and change the partition to something OS X can read like ExFAT, or MSDOS. Once that change has been made, OS X should be able to see it; allowing you to manipulate the partition.

The other option is to load up FUSE for OS X which will allow you to read/write ext2, ext3, and ext4 file systems. I am not a fan of loading up applications for one time use, but I wanted to let you know about it.

  • disk0s4 already is HFS+ formatted (disk0s4: Apple_HFS). So your answer is somehow...surprising. – klanomath Jun 9 '16 at 13:35

Your partition table seems to be hosed:

  • the type of disk0s2 should be:

       2:          Apple_CoreStorage Macintosh HD           86.5 GB   disk0s2

    instead of

       2:                  Apple_HFS Macintosh HD           86.5 GB   disk0s2

I recommend to backup Macintosh HD with Time Machine immediately. Booted to Internet Recovery Mode erase your disk. Finally install a new system and import all data with Migration Assistant or restore the backup.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .