0

I am using a MacBook Pro Late 2011. I lately took out the hard drive and replaced it with a new one. The old HDD still has OS X installed on it, so basically I did nothing before taking it out. Now I want to access some files on it, so I have a SATA to USB bridge. When I spin up the drive, I can find it in Disk Utility and with diskutil list, plus in the system report under the USB tab.

However, when I connect it, I get a message saying "The disk you inserted was not readable by this computer". As a result, I cannot access it in the Finder. I thought that maybe I could boot from the disk because it has OS X installed and all, but the disk is not shown if I access "Startup Disk" in the system preferences. It does also not show if I do a reboot and hold down the option key.

Where should I go from here? Does anyone know how I can read the contents of the disk? It has never been used for anything else than OS X, as it has been in my Mac since I bought it. Ideally, if I could access the files from within my current installation of OS X, that would be perfect, but whatever works...

Any help is much appreciated!

EDIT: The hard drive is a Hitachi 5K750-500 (500GB). It is the standard one that the MacBook was delivered with. The SATA to USB adapter is an ICIDU AI-707944 ("Hard Disk IDE/SATA to USB 2.0 adapter").

  • Did you have FileVault enabled? – absenthecon Jun 8 '16 at 23:22
  • @TrentFitzpatrick No, I did not. No encryption enabled. – Andy0708 Jun 9 '16 at 16:22
  • Who is the manufacturer and what is the model of the SATA to USB bridge? Who is the manufacturer and what is the model of the drive? – David Anderson Jun 9 '16 at 17:20
  • @DavidAnderson I added the information to the question. Thanks. – Andy0708 Jun 9 '16 at 17:46
1

This is as close as I can get to an answer.

It would appear the transfer rate for the bridge is 150 MBps (1.5 Gbps). This would indicate conformance to the SATA I standard. The drive has a transfer rate of 300 MBps (3 Gbps). This would indicate conformance to the SATA II standard. Even though the connectors appear to be the same, these two standards are incompatible.

Some drives have a jumper you can insert to force a SATA II drive to emulate the SATA I standard. The installation instructions for your drive do not indicate this to be true. You may want to examine the drive for possible jumpers or other instructions.

For other readers, I will mention that the SATA III standard of 600 MBps (6 Gbps) is compatible with the SATA II standard. The hardware will transfer data at the lesser of the two speeds.

It also does not help that I can not find a web site that states the bridge is Mac compatible. All sites only mention Windows compatibility.

  • Thanks a million for your research, David! I just borrowed this bridge from a friend and didn't put much thought into the specifics. After seeing that it did not work, I did notice that it only said Windows compatible on a website that I checked, but was not 100% sure that it was the issue. I will try to find/buy another bridge and be back with my results. Until then, thanks so much! – Andy0708 Jun 9 '16 at 19:25
  • I just tried with a different cable, and it worked perfectly. Thanks a lot! – Andy0708 Aug 18 '16 at 11:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .