2

I can connect to a Wi-Fi Network with my MacBook Air (Yosemite 10.10.5) but do not get Internet.

Other MacBooks and Windows laptops I connected to the same Router via Wi-Fi receive Internet. With an Ethernet connection to the Router I also receive Internet.

What I have done so far:

  • Clean install of OS X Yosemite (in Apple Store), there is no firewall etc. installed.
  • Multiple restarts of MacBook and Router.
  • Deleted Wi-Fi preference files.
  • Pinged myself in the terminal: 100% packets received
  • Pinged router in the terminal: 40% packets received
  • Tried Lookup in Network utility, works fine, e.g. result: www.google.com -> 216.58.213.4

I really do not know what to do, the DNS service seems to work fine, also I can exclude a problem with the Router since other people can go online via Wi-Fi and I can go online via Ethernet. It is a clean Yosemite install.

What else can I do?

  • Try following the steps in the answer to this question – Munesawagi Jun 6 '16 at 15:15
  • Even though other computers are connecting okay via Wi-Fi, have you at least power cycled the Router? If not, then do so and test your Mac again using Wi-Fi. I've seen cases just like yours where other systems has no problem yet power cycling the Router is what cleared up the issue with the one that connected but still didn't get to the Internet. – user3439894 Jun 6 '16 at 15:18
  • @Angelplayer - i went through that as well except for the "dnscrypt/dnscrypt-proxy" which I did not get - is there a guide how to fix that? – StnBnu Jun 6 '16 at 15:27
  • @user3439894 thanks - did that now, did not help. I get a new IP adress and again DNS lookup works but nothing in the browser – StnBnu Jun 6 '16 at 15:38
  • What Browsers have your tried, just Safari or others? – user3439894 Jun 6 '16 at 15:40

You must log in to answer this question.

Browse other questions tagged .