2

A friend of mine gave me his old MacBook6,1. While I was trying to format it and run some diagnostics, I noticed a few weird problems, which I think are due to a corrupted EFI firmware. Here's what I noticed:

  • Some keyboard keys don't work under certain conditions (but a USB keyboard works fine);
  • I cannot hear any startup sound, but the audio volume is up and it works fine when using OS X;
  • The power button doesn't behave correctly: if I press it when the system is running, it shuts down immediately. This should only happen if I hold it for a few seconds;
  • Some startup key combinations don't work (either on the internal or on a USB keyboard), therefore I cannot reset the PRAM/NVRAM and the SMC, I cannot access the recovery partition and I cannot boot from an external drive. However I can boot verbose and single user mode;
  • The LED on the MagSafe connector stays green when the computer is powered off, and sometimes it turns orange when it is powered on. The battery is 100% charged;
  • Sometimes the fans suddenly start to spin at their maximum speed.

Of course I thought I had to reset the firmware, however I did not found a compatible firmware for this computer anywhere (including Apple Downloads).

I tried reinstalling OS X; the installation succeeded, but all these problems were not resolved. What do you suggest? Is there something else I could try? If not, since I'm not willing to spend money to fix it, I think I'll tear it down for parts. Thanks.

  • 1
    Have you tried the hardware test? support.apple.com/en-gb/HT201257 – Tetsujin Jun 5 '16 at 14:46
  • @Tetsujin I can't: the key "D" is not recognized on startup, so I cannot start AHT. – user2747949 Jun 5 '16 at 14:54
  • from the external USB too? [I've never tried startup keys on a laptop from external, so I'm not sure if it even should work - I guess you could test other known-good key-combos] – Tetsujin Jun 5 '16 at 15:15
  • 1
    @Tetsujin It should work with an USB keyboard – it does work with all my other laptops – but on this, it doesn't. That's what made me think of a serious firmware corruption. – user2747949 Jun 5 '16 at 15:17

You must log in to answer this question.

Browse other questions tagged .