2

Okay, so I've tried so hard to set up Soundflower on my computer, and it doesn't seem to work no matter how many tutorials I watch. I'm running OSX El Capitan 10.11.4 on a MacBook Air 13-inch from early 2015. What I'd like to do is be able to record my computer audio, my microphone audio, and my screen at once, and hear my computer audio through my headphones.

Here's everything I've done so far.

I have the El Capitan Soundflower version. I can't post the link, because I don't have enough reputation points.

I went into Audio MIDI setup and made a Multi-Output Device, selecting Built-in Output and then Soundflower 2ch. enter image description here

I also set up an Aggregate device, merging my Built-In Device (this is what my headphones show up as; they're Urbanear Plattan) with Soundflower 2ch. enter image description here

I set my output to the Multi-Output Device, and my input to the Aggregate Device (system settings>sound>output/input). Then, I went into QuickTime>file>new screen recording and set the input to Soundflower 2ch. I can't hear anything when I play my video back. Can anyone walk me through the correct process, or tell me what to change? It would be much appreciated.

  • Long time since I used Soundflower, it got too crashy for me - but iirc, you either set the aggregate to be the input. Right click it 'Use this device for sound input'. ... or you set Soundflower to be input, then handle which channels are which in Soundflower's drop menu, top right near your system clock. Whichever way, you then set that to be input in QT. Let me know which works ... – Tetsujin Jun 5 '16 at 7:25
  • After further research, Soundflower v2b doesn't have that drop menu [soundflowerbed] any more, so it's the aggregate you need, as per above. – Tetsujin Jun 5 '16 at 7:29
  • @Tetsujin Thank you for the help. I already have the aggregate set as my input, and when I record with the aggregate as the input in QT, all I can hear is my own voice and not the computer audio. I think my problem might be that Soundflower itself isn't working. I'm going to try taking it off my computer and re-installing it to see what's going on. – Marci Greene Jun 5 '16 at 21:10
  • @Tetsujin Okay, so I ran the uninstall script twice and it still is on my computer, which is really frustrating, but I went ahead and downloaded it again from this link . I then re-checked the soundflower2ch boxes in Audio MIDI, and MIDI crashed. Back in QT, the issue is still present. – Marci Greene Jun 5 '16 at 21:21
  • You might end up having to go with the paid alternative, then - which is what I switched to quite some time ago. Audio Hijack from Rogue Amoeba - there's some config examples here - apple.stackexchange.com/questions/203004/… – Tetsujin Jun 6 '16 at 6:19

You must log in to answer this question.

Browse other questions tagged .