1

Friend running MacOS 10.7.5 wanted to update the OS but stick with iPhoto. So, we updated to Mavericks before realizing that she had an “old” version of iPhoto, version 9.1.5, which I figured we could update later. (In hindsight, I should have updated iPhoto when she was still on 10.7.5, but here we are.)

The combination of OS 10.9.5 and iPhoto 9.1.5 shows iPhoto as a non-launchable program. When I look at her App Store > Purchases, it shows iPhoto as “installed” and button is greyed out. So, I figured no problem, I kept all the iPhoto updaters from that era. However, when I run the 9.2.1, 9.3.1 or 9.4 or 9.4.3 updater, they all report that “the version of iPhoto installed on this Mac must be updated through the App Store” — which now is not possible.

I also have the iLife ’11 DVD, so I uninstalled her copy of iPhoto (the app and the receipt files located both in /Library/Receipts and in /var/db/receipts) and installed from iLife ’11. Installed just fine. However, I’m left with a non-launchable iPhoto, although it’s a slightly newer version 9.2.1. When I run any of the updaters (9.2.3, 9.3, etc), it gives me the error message “iPhoto 9.1 or later is required to install this update.” which is a bogus message, but probably something that Apple has ceased to care about.

As far as I know, there was never an iPhoto 9.6.1 updater put out by Apple — by that time it was updated via the App Store.

Any ideas on how I an get a runable version of iPhoto on this Mavericks Mac? (Yosemite is not the answer for other reasons I won’t go into). I do have Mavericks installed on a bootable external with an iPhoto that works (not exactly sure which version, but probably either 9.4.3 or 9.6.1). I know I could copy the app, but what support files also need to be copied. Or is there some way to “trick” the current updaters into working?

  • 1
    Do you need to update iPhoto? I am using 10.9.5 OS X Mavericks, and I could send you my iPhoto.app if you want. Then you could just replace your system iPhoto with the one I send you... – thepiercingarrow Jun 5 '16 at 0:42
  • Yes need to update since the current version is unlaunchable (has the "no" sign through it). – user75281 Jun 5 '16 at 2:54
  • I do have a running Mavericks and can get the iPhoto app, but I know mine is tied to my AppleID. Also, I'm thinking there are other supporting files that need to be updated as well. My friend's photo library is too important to take chances (although we do have a backup) – user75281 Jun 5 '16 at 2:55
  • hmm... have you tried contacting Apple Support? It seems like this would be a bug... – thepiercingarrow Jun 5 '16 at 2:59
  • Unfortunately this machine is a 2011, long past its Applecare support. Even so, I'm guessing they are all geared up to support Photos, and not oddball upgrades to Mavericks, now that it's 2016 – user75281 Jun 6 '16 at 17:28
1

Turns out that the iPhoto version was being reported incorrectly. It was really version 9.0 (from the iLife '11 DVD) not 9.2.1 as it said in the GetInfo box, so all of those later updaters were being honest. What I really needed was the 9.1 updater found here https://support.apple.com/kb/DL1322?locale=en_US Once I got 9.1 installed, I was able to bring it up to 9.4.3, which will work just fine.

0

If you delete iPhoto, then you can simply go into the Purchased tab of the Mac App Store and re-install iPhoto (the latest version).

  • Unfortunately it does show iPhoto under Purchases, but the button is greyed out and says "Installed". I guess I was hoping more for getting one of the previously downloaded iPhoto updaters to work -- to get past that bogus error message that says you have to have iPhoto 9.1 or higher -- obviously the updater isn't looking at the actual installed version (which in this case is 9.2.1), but something else. Anybody know? – user75281 Jun 6 '16 at 17:26
  • @user75281 well, if you actually deleted it (not just in the trash), then a restart might reset the button to allow you to downloaded. If that doesn't work, you can try cleaning all of the caches and any App Store pref files. – At0mic Jun 6 '16 at 18:25
  • The App Store still hung onto the idea that iPhoto was "installed" even after emptying the trash and restarting. I suspect what was going on was that the App Store is entirely focused on installing iPhoto 9.6.1, and if your OS doesn't support that (everything before Yosemite), then they're not going to allow it to be installed. Fortunately, I had the "old fashioned" installers to steer around the issue. – user75281 Jun 7 '16 at 19:51
0

If you have another Mac running a compatible new version of iPhoto, you can just copy the iPhoto.app file from that Mac into your Applications folder. You might need to authenticate with the user password on the recently updated Mac but that's it. I did this after upgrading to El Capitan and it worked fine, no installer or updater required.

There is also a Photos app in El Capitan, which I ended up using instead of iPhoto, actually I deleted iPhoto.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .