I updated my 5c to iOS 9.3.2 and since then the phone has been behaving as though the headphone are plugged in.

Neither speaker nor microphone work normally when taking calls - I hear nothing and the caller cant hear me. But when I switch it to speaker during a call it works fine, and I can hear the ring tone. Sounds in apps like Spotify dont work either.

Of course I've turned the phone on and off again.

Would anyone know what I can do?

  • Did you try plugging in a headset and unplugging it again? – Tyson Jun 4 '16 at 12:18
  • I tried it before and no result. Tried again just then and it worked! Thanks – MeltingDog Jun 4 '16 at 12:47
  • Did you check if the entrance is clean? Did you tried to blow on it? Did you tried to check any damages on it? Did you tried any software solution you can think of? – Ismael Miguel Jun 4 '16 at 14:38

Try plugging in a headset and unplugging.

  • This was already said in a comment. – Ismael Miguel Jun 4 '16 at 14:34
  • 2
    @IsmaelMiguel right, my comment, when OP confirmed that it solved the problem I made it an answer. – Tyson Jun 4 '16 at 14:47
  • You're right. I didn't read it all. My bad. Flag mine as obsolete when you see it. – Ismael Miguel Jun 4 '16 at 14:49
  • I'll add that I had to jiggle the headphone jack around a bit as well – MeltingDog Jun 4 '16 at 23:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .