1

I ordered and installed an SSD in my 2010 iMac (10,1). I tried installing El Capitan via USB. This failed and searching the internet I found out that it is best to use the original install disks.

So I booted using the 10.6.2 Mac OS X install CD. However, I cannot install since the SSD does not show up in Disk Utility or the Installer. However, when I go back to the El Capitan installer, the disk does show up. It has one partition, HFS Journaled, GUID.

What can I do to make the 10.6.2 installer see the SSD?

  • Does diskutil list not show anything? How about the USB device tree? – JMY1000 Jun 3 '16 at 4:46
  • Yep, I ran diskutil list via the 10.6.2 and the El Capitan installer. On El Capitan the list showed the SSD as disk0 with two partitions: disk0s1, Apple_Partition_Map, and as disk0s3 Apple_HFS. On 1.6.2, the list starts at disk1, no sign of disk0. – Docman Jun 3 '16 at 19:29
  • What about the USB device tree? – JMY1000 Jun 3 '16 at 19:46
  • I am not sure why there would be anything on the USB device tree, since the disk has a SATA connection. If I check in the system profiler of 10.6.2, the SSD does show up. There is no system profiler in the El Capitan installer, but since I can select it there as an install disk I assume it would show up there too. – Docman Jun 4 '16 at 7:55
  • "I tried installing El Capitan via USB" was the reason why I asked. – JMY1000 Jun 4 '16 at 7:57
1

I solved the issue by installing El Capitan on the USB (via another Mac) and booting from there (a full install, not just a boot disk). The El Capitan booted from the USB did see the SSD, so I could install El Capitan from the USB onto the SSD.

The core issue was that Apple seems to have added third party SSD support after 10.6, so installing 10.6 was never possible.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .