3

I am trying to update to El Capitan. I am being asked for my Apple ID and password. I entered both correctly however I am being asked to enter a verification code after the password (see screenshot). This makes no sense, it's absurd, and very unlike Apple. Any thoughts on how to fix this?

Note: I updated the password using the 2-step verification process, but the new password still does not work.

enter image description here

6

This is perfectly normal behavior for an account that has Two Step Verification enabled.

In order to have enabled it, you must have a trusted device enrolled that can receive either SMS or be found by "Find My Phone" because that's the device which will receive the verification code you enter after your password. So, just enter the verification code that Apple sent to that trusted device after your password and you will be able to access the Mac App Store.

How do I turn off two-step verification?

  1. Sign in to your Apple ID account page.
  2. In the Security section, Click Edit.
  3. Click Turn Off Two-Step Verification.
  4. Create new security questions and verify your date of birth. You'll get an email confirming that two-step verification for your Apple ID is off.
  • "enter the verification code" prepended with the Apple ID password. You still need the normal Apple ID password to be entered in the password field. – grg Jun 2 '16 at 17:35
  • Even if I append the verification code to my password it still does not work. I had to turn off 2-step verification and then login with my apple id and password. – lilredindy Jun 2 '16 at 17:57
  • 1
    I've never seen apple do something like this b4, where they ask you to enter STANDARD information and then return an error saying, "No, actually the STANDARD way is not right, this is how you need to enter it" VERY BAD UI. – lilredindy Jun 2 '16 at 18:01
  • @user28801 - RSA SecureID used this very method of two-factor authentication. The UI could be configured as a three field authentication (username, pass, token) or utilize two fields (username, pass and token). This is much more common than you realize. – Allan Nov 19 '17 at 16:05
0

The solution is to insert your 2-way-auth-code directly after your Apple ID password in the same field, where you're asked for your normal password.

0

I had this problem when I restored my Mac. Trouble is that the restore installed a clean version of Yosemite. So, here’s what you do: Type in your appleid password and hit enter. That brings up that image shown by the OP. This will ding your iPhone (or other Apple device that you normally use 2factor with). Press Allow. Then a 6 digit code appears on your iPhone. Now append those 6 digits to your appleid password.

That process worked for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .