2

I do a lot of writing on iOS: mostly email (in Outlook for iOS) and plaintext drafts (in Ulysses) using an iPad Pro with a keyboard. My writing style happens to include:

  • Lots of bulleted lists
  • Seriously, like way too many
  • Sometimes even when they may not totally be needed

Here's the problem:

Sometimes, when I type:

* Blahblahblah

...it changes to:

I Blahblahblah

What I've determined - this problem occurs:

  • Inconsistently - I can repro it regularly, but not all the time
  • After some (variable) amount of additional keystrokes happen - the text appears as typed (an asterisk) at first, then sometimes changes after I add more chars later - sometimes one later, sometimes a bunch later, sometimes not at all.

Putting it together, I'm thinking it's caused by some form of autocorrect in the OS.

  1. Can anyone confirm if that sounds like the culprit, or how to determine if it is?
  2. If so, how can I teach autocorrect that I like bullets (and markdown), thank you very much, without just turning AC off entirely, robbing my loved ones of a regular source of humor?
1

You can set iOS to not autocorrect something by adding it as an autocorrect shortcut. This also lets you see if autocorrect is to blame without disabling it.

Unfortunately, iOS doesn't let you set text replacements of less than 2 characters. OS X is supposed to not either, but you still can, and iCloud will sync the settings over.

  1. Go to System Preferences → Keyboard → Text and click the + in the lower left.
  2. For both the ‘Replace’ and ‘With’, type an asterisk.
  3. Wait for iCloud to sync the settings over to your iOS device. Your new text replacement should show in Settings → General → Keyboard → Text Replacement.

If the asterisk still changes, there's likely something else going on here, and I would suggest disabling autocorrect entirely just for testing purposes to establish if it is the root cause of the problem.

  • Testing this now. Do you happen to know if AC settings sync across devices (assuming you have general settings set to sync over icloud)? – Jaydles Jun 2 '16 at 16:01
  • @Jaydles It should sync across iCloud. Should…! – grg Jun 2 '16 at 16:02
  • Hmm - problem. That field requires at least 2 characters, and spaces don't seem to count. – Jaydles Jun 2 '16 at 16:04
  • 1
    @Jaydles Oh, I tried it on OS X and it let me! Apologies, I don't have access to an iOS device right now. Given that it syncs, if that's an option for you, I suggest adding it in System Preferences → Keyboard → Text. – grg Jun 2 '16 at 16:06
  • @grgarside Hmm… that’s interesting! I had previously set one of my replacements in OS X to a string with more than one character because OS X wasn’t letting me put in just one. However, I just tried removing those superfluous characters now after reading your comment and it actually worked! 😲 – アリスター Jun 2 '16 at 18:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .