4

I have a toolbar that semi-randomly every couple of minutes flips the Airplay icon on:

toolbar with AirPlay

or off again:

toolbar sans AirPlay

How do I freeze it into a state of either always on or always off? The current behaviour of occasionally shifting the seven leftmost icons a step to the left or right, because some AirPlay unit went in or out of range (or whatever's happening under the hood) is maddeningly distracting.

5

You can disable the icon in the menu bar by ⌘-dragging it off the menu bar, which unchecks the option in System Preferences → Displays entitled "Show mirroring options in the menu bar when available".

Should you wish to use the menu bar item, you can check this box again, or just use the AirPlay Display dropdown in System Preferences → Displays to connect to an AirPlay device.

  • 1
    Sweet! I had found and attempted to resolve by unchecking that checkbox before, seemingly without effect, but ⌘-dragging the icon off the menu bar when there did get rid of it (and later on re-checking the pref puts it back). Thanks! – ecmanaut Jun 3 '16 at 16:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .