1

For years now, I have managed a mixed-device shop, with Windows 2008/2012 servers. Typically, connections are made using smb://share_name, users authenticate, and file shares are then selected. For whatever reason, as of today, this is no longer working for a subset of Macs.

I have tried the alternative cifs:// protocol, using IP instead of device name, connecting via Ethernet instead of wireless, using FQDNs instead of machine names, changing DNS addresses, etc. and I still cannot see my Windows shares.

All Macs are running El Cap 10.11.5. The servers in question are Windows 2008 R2 and 2011 Home Server. All Macs and servers have been rebooted and are at their current SP/patch levels.

Does anyone have a fix for this issue?

EDIT: I am seeing the same problem in other networks connecting via afp://. I have no issues connecting to the same machines via RDP, or VNC. It's just a file sharing issue, and it's not relegated just to Windows servers.

EDIT 2: I have noticed also that there are no devices displaying under the Network sidebar tab, even though there are dozens of known devices on our network, and these devices are displaying fine on other Macs.

  • What does running smbclient -L <serverip> -U <username> in a terminal give you? It should give you a list of shares. You could also try connecting to a share with smbclient //<serverip>/<sharename> -U <username> which will give you a simple shell if it connects succesfully. Any firewall configured on the affected machines (that wouldn’t explain why VNC/RDP works though). No servers appearing in the sidebar could mean netbiosd isn’t running (does netbiosd appear in Activity Monitor process list?) – Dan Jun 7 '16 at 12:36
  • netbiosd was not running. I loaded it using sudo launchctl unload -w /System/Library/LaunchDaemons/com.apple.netbiosd.plist. Still don't see anything in the Network pane, although on other Macs in the environment, I see plenty. – Dave Jun 7 '16 at 13:05
  • All firewalls are disabled on the servers (firewall services are managed at the hardware side facing out), and the firewall on the Mac is turned off. I am not using Little Snitch, Hands Off, or any of those types of apps either. – Dave Jun 7 '16 at 13:07
  • Connecting to the smbclient via CLI gives me this error: session setup failed: NT_STATUS_LOGON_FAILURE. I verified the login credentials to be correct. – Dave Jun 7 '16 at 13:08
1

Try running this command in Terminal:

sudo defaults write /Library/Preferences/SystemConfiguration/com.apple.smb.server.plist SigningRequired -bool false
  • Tried with no success. It doesn't even search for the shares. It fails quickly, for afp, smb, and cifs alike. – Dave Jun 6 '16 at 15:02
  • 1
    Verify that the correct time is set on the systems having connection issues. I've seen strange things like this happen with incorrect time settings on client systems. – KarlC Jun 8 '16 at 0:09
0

Do you have /etc/nsmb.conf or ~/Library/Preferences/nsmb.conf files on either the machines that do or do not manage to connect? If you do, what is their content?

If you do the following commands on a non-working OSX box; what do you get back?

ping <servername>

smbutil lookup <servername>

smbutil status <servername>

smbutil identity -N //<servername>

smbutil view //<username>@<servername>

mkdir ~/WIN
mount_smbfs //<username>@<servername>/Path/To/A/Share ~/WIN

If you could do the same on a working OSX machine to compare & contrast, that would be very useful.

  • There is no nsmb.conf file on the non-functioning Mac in either of those directories. I will have to look at the functioning ones when those users are on-site. – Dave Jun 7 '16 at 21:57
  • I cannot ping the server, but smbutil lookup <Server> yields: Got response from <IP address> IP address of <Server>: <IP address>. – Dave Jun 7 '16 at 21:58
  • The other commands return smbutil: server rejected the authentication: Authentication error. – Dave Jun 7 '16 at 22:00
  • FYI, if I substitute the server name with its IP address, I get a status response. The other commands such as view, and identity give me an auth error, regardless. I am using credentials that are known to be correct, and work on other machines, and Windows devices. – Dave Jun 7 '16 at 22:03
  • The status command doesn't use NetBIOS lookups, only DNS. I guess the Windows hostname is not in your DNS hence why that command required the IP. Strange the ping didn't work - given no host based firewalls. Does the Mac have an ARP entry for the server? (arp -a | grep <server ip>) – aid Jun 7 '16 at 23:36
0

Make sure SMB sharing is enabled under the options in the sharing panel.

  • It is. I don't have issues sharing FROM this Mac. I have issues gaining access and visibility TO other shares (mainly Windows servers). – Dave Jun 8 '16 at 15:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .