2

History: Running an iMac late 2011 and updated the OS to Yosemite when the computer stopped booting. I have a history of killing HDD so I figured it was a bad HDD and I went to change the drive. Before I changed the drive I wanted to try and recover some of the files and using my Macbook I set the iMac in Targeted disk mode and I was able to access the drive and copy some of the files. Due to the length go time it took I shut down the computer and tried to pick up where I left off on the next day. This time target disk mode did not work. Since I had copied most of the important stuff I decided to change the drive and try and clone the the drive if it would spin up.

I extracted the 1TB drive and cloned it using a disk duplicator. I plugged the Dock into the Macbook and Both HDD would spin and Disk Utility acknowledged their presence but would not mount either drive. I figured it may be a conflict because they were clones and I shut down and removed one of the drives Drive 1 (Original iMac drive) Using a program called DriveDX I can monitor the overall health of the drive. Drive 2 is Status OK and GOD overall Health and GOOD performance rating. I tested Drive 1 and got similar results. I also ran self test with good results. I ran the First Aid on both Drive 1 and 2(Disk Utility) Both drives resulted in the same message:

"First Aid process has failed. If possible back up the data on this volume. Click done to continue."

repairing file system.
Checking journaled HFS plus Volume.
Checking Extents overflow file.
checking catalog file.
Missing thread record (id=18438430)
Missing thread record (id=18441061)
Missing thread record (id=18441109)
Missing thread record (id=18444964)
Missing thread record (id=18543123)
Missing thread record (id=18549821)
Incorrect number of thread records
Incorrect number of thread records
Checking Multi-linked files.
Checking catalog hierarchy.
Invalid directory item count
(it should be 59 instead of 77)
Missing thread record (id=18438409)

I will spare you the list but it goes on for several pages. Skip to the bottom and it says:

Checking extended attributes file.
Invalid node structure
The volume Macintosh HD could not be verified completely.
File system check exit code 8.
Updating boot support partitions for the volume as required.
File system verify or repair failed.
Operation failed...

From what I can tell the overall health of Drive 1 and 2 are good they both spin freely but neither will mount to the computer which appears to be a file structure issue?? How can I repair the drive or can I recover the drive all? I am not willing to spend $$$ on Data recovery because I was able to get most of the important stuff off the drive when I had it in Target disk mode. At this point I am just puzzled by the failure in the first place and would like to try and understand what happened and how to fix it.

  • 1
    Have you tried Apple Hardware Test to see if there is an issue with your SATA controller? Hold "D" while booting from a powered of state plugged into AC power – Allan Jun 1 '16 at 13:17
  • I have run the test on two different machines – Mark OneWolf Jun 1 '16 at 17:48
  • The test should be on the original machine where the problem manifested. – Allan Jun 1 '16 at 17:51
  • Whatever directory damage was done to the first drive likely would be duplicated to the clone [depending on method used to clone]. I'd say this would be the perfect job for DiskWarrior. Its sole purpose is to rescue this type of corruption. Unfortunately, I don't think it has a free trial, so you might want to see if anyone else will support my suggestion before going all out for it. [See if anyone adds a number to the left of this comment as a gauge of support, or comment underneath if anyone specifically doesn't] – Tetsujin Jun 1 '16 at 18:56
  • Upvote this comment if you think DiskWarrior is the wrong suggestion. [The idea being that the OP doesn't waste money if my idea wasn't the best] – Tetsujin Jun 1 '16 at 18:58
1

Invalid node structure is bad news. You should backup as much data as possible then try repartitioning the drive using Disk Utility.

If the repartition fails or the same issues crop up again it'll be time to replace that hard drive.

0

The fact of not mounting a volume from a HDD might related to other issues as hardware problems (talking by self experience). The alternative of spending in third part software is to use a third disk to save data and format the disks again. I think you should use it to save your data and go deep by this steps:

  • Make sure your hardware is ok by testing with another HDD verified. In my case, Disk Utility found 1TB in a 120GB SSD.
  • Make sure your HDD is physically ok by checking SMART status (in the bottom of the Disk Tools window when you click in the disk).
  • Format your disk again but making new partition schema, not only erasing it, remember that the scheme must be GUID in order to be bootable.

By copying back the data you save in the third disk, you are already will be testing it again. No problems should appears in the test you do just after the copy.

  • Drive 1 was the original HDD from the iMac Drive 2 was a new 1TB drive I cloned the iMac drive to. Drive 2 was verified and working in good condition prior to the cloning. I cannot access Drive1 to transfer files. I may be able to format Drive 2 in order to reuse it for something else, but I wanted to try and repair the drive. Is there another Program I might be able to use to access the files on Drive 1? – Mark OneWolf Jun 1 '16 at 18:35
  • I think I used Data Rescue prosofteng.com/datarescue-mac-data-recovery with good results. You my try Disk Rescue from paragon: paragon-software.com/home/rk-mac. Both got free versions, might work. – Gustavo Jun 1 '16 at 21:31
  • Thank you, Data-recovery free version seems to an analysis only. I will keep that in mind how does this compare with Disk warrior? Rk-mac seems to be a system recovery and not really sure, based on what I read that it will help with external drives. Am I understand the program correctly? – Mark OneWolf Jun 3 '16 at 6:58
  • The software I used was Data Rescue, but it does not have good qualifications in App Store. I read an article that says this softwares don't go much further than Disk Utility, maybe if you buy pro versions but a cheap solution might be a technical service because they got something professional. Some manufacturers as Seagate got free data recovery software available in their websites. – Gustavo Jun 11 '16 at 18:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .