4

I am trying to use Kiwi for Gmail as my default email reader (for example, when wanting to share a link via email, I want Kiwi to open up, rather than the Mail application by Apple).

In the Kiwi preferences, it says to use the application Mail to change the default email client:

enter image description here

So, in Mail > Preferences, I have set Kiwi as the default email reader:

enter image description here

However, the problem is that, after closing Mail, Kiwi is not the default client., despite I changed it before. In fact, if I reopen Mail, Mail is still set as default email reader. It seems like changing the default email reader doesn't take effect, when closing Mail.

Can anyone help me to fix the issue?

  • Have you tried setting it in Mail (not closing it), going over to Kiwi, checking the box in the first screenshot then closing Mail? (The checkbox could just be to 'remove' Kiwi from being the default mail reader, but it's worth a try) – Brick Jun 1 '16 at 12:29
  • @Brick yes, unfortunately it doesn't work :( – mgiordi Jun 1 '16 at 12:30
1

I had this problem too, when trying to set Airmail.app as my default email client. I found a solution (after many failed attempts) here:

http://docs.airmailapp.com/airmail-for-mac/setting-airmail-as-the-default-email-client-airmail-for-macos

All credit goes to the author of that article, and the instructions should apply for any email client, not just Airmail.

The key is to reset Apple's LaunchServices database before opening Mail.app. Here are the instructions from the above-linked site (slightly modified):

  1. Open Terminal (Cmd+Space Bar and enter Terminal)
  2. Copy & paste this command:

    /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/Support/lsregister -kill -r -all local,system,user
    
  3. Press Return to submit the above command and wait for it to finish (might take a few moments)

  4. Open Mail.app and set your default email reader

This worked for me. I noticed though that, when right-clicking a file in Finder and choosing "Open With", the menu was very slow to be populated with a list of apps (note that the LaunchServices database also controls this list). So I restarted my computer and everything was fine.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .