The bug mentioned in this question continues: Spotlight search on iOS 9 returns no results.

I've tried

  • Sending myself an e-mail (yes really; this occasionally works for a few minutes)
  • Toggling off all entries in the settings for Spotlight (takes forever)
  • Restarting
  • Rebooting
  • Toggling contacts on and off (suggested in several places, at least of iOS 8)
  • Re-enablining only Contacts in Spotlight search settings (said to work for iOS8)
  • All of the above in every possible pairwise combination

None of these work for more than a few minutes. Most do not work at all.

Basically, for practical use, especially "in the field", this effectively bricks my iPhone.

Has anyone had reliable success with iOS 9 fixing this issue?

  • Have you tried restoring your iPhone? So re-installing iOS through iTunes on your computer? Commented Jul 8, 2016 at 16:58
  • @ClaytonJones: Yes, in fact I've gone one better: I restored onto a fresh phone with a fresh iOS. I believe others have tried that as well without success.
    – orome
    Commented Jul 8, 2016 at 17:01
  • Ah ok, that normally seems to fix a lot of problems that 'Erase All Content and Settings' can't do. Commented Jul 8, 2016 at 17:03
  • @ClaytonJones: Yeah, I'm hoping there's a solution that's short of that. The ones I'm facing seem to come pretty close to "switch to the Google ecosystem", which I'm honestly leaning towards at this point.
    – orome
    Commented Jul 8, 2016 at 17:08
  • Have you contacted Apple over at getsupport.apple.com?
    – owlswipe
    Commented Jul 9, 2016 at 0:00

4 Answers 4


I've tried

  • sending myself an e-mail (yes really; this occasionally works for a few minutes)

  • Toggling contacts on and off (suggested in several places, at least of iOS 8)

Both of these, the only specific attempts you've made to solve your issue (and the only two that seem to be reported as effective) both involve accounts.

My best guess for why your issue is occurring (based on this connection) is that something with your email accounts is screwed up, giving Spotlight a format of information it can't handle, effectively crashing it. The idea that your accounts are causing it is one uncommon thing that isn't changed by a factory reset, given that you probably re-signed-in to at least one of your accounts immediately after a reset.

How should you stop this issue from occurring?

  • Sign out of your email accounts (in your mail settings) and delete all of the contacts, emails, calendar events, and notes from your iPhone.
  • Sign out of your iCloud account and remove any information associated with that account from your phone (this might involve a factory reset without restoring from a backup and without signing into your iCloud account).
  • Turn off Siri (which has access to and can control your accounts).

Once you delete all email/account related data from your iPhone, I suspect this issue will cease to occur to you, and Spotlight should start working again.

Other tips from other forums:

Make sure you're not hiding contacts in the Contacts app.

Shut down everything from appearing in Spotlight then only enable Contacts.

Reset your network settings in Settings->General->Reset

The only official suggestion from Apple

Make sure you're in a country that supports Spotlight Search, that your language is set to a language spoken in one of those countries, and that your device region is set to one of those countries.

  • I've also tried just removing Mail, Contacts, and Calendars from Spotlight search entirely (and then rebooting, hard reseting, etc.); but to no avail. Shouldn't that have fixed things if something with my email accounts is screwed up?
    – orome
    Commented Jul 10, 2016 at 21:17
  • @raxacoricofallapatorius That should work unless there's a bug with Spotlight (i.e. maybe it already crashed so it wasn't able to un-crash and remove mail data?) so my suggestion would be to try fully removing every account (including iCloud account along with all your Pages docs, News data, iCloud notes, etc. AND email accounts, fully) and trying again. In the meantime, you can use a mail app like Cloudmagic.
    – owlswipe
    Commented Jul 11, 2016 at 1:51
  • @raxacoricofallapatorius So, did it help?
    – owlswipe
    Commented Jul 13, 2016 at 2:14
  • To be clear I'm "looking for an answer drawing from credible and/or official sources." That's what the bounty is for.
    – orome
    Commented Jul 14, 2016 at 11:04
  • @raxacoricofallapatorius I added links to other forums I thought might help you, with ideas you haven't tried already. Also, I linked to Apple's only page about Spotlight not working, which is just a list of countries it's supported in. I'm sorry that I couldn't really draw from credible sources, but I think the multitude of things I've laid out will surely solve your issue if it's solvable. Just try them all (especially my suggestion to disable accounts!) and tell me what works and what doesn't. You absolutely don't have to award me the bounty because I didn't answer question like you wanted.
    – owlswipe
    Commented Jul 14, 2016 at 12:12

I solved this way: Go to the Contacts App -> Groups -> Disable All iCloud.

In my case is useful because my contacts are synced with Exchange contacts.


I have this problem a couple times a day. Until it's fixed I've had to double click the home button to bring up the recently used apps. Then I swipe up on two or three of the most recent ones. Then try searching again in Spotlight. If it doesn't work try closing a couple more. Not sure what the deal is but that always works for me


I think as of 9.3.2 and later there is a fix.

I've had this since 9.x, usually associated with running Reeder.app but not always. Behaved like a free RAM and timing bug. Quitting background apps fixed transiently.

From my own experience and what I read 9.3.2 alone fixed it for some people. Others, like me, need 9.3.2 (or later) AND a full backup/wipe/restore cycle.

  • I have 9.3.3 and it persists.
    – orome
    Commented Jul 30, 2016 at 21:12
  • Did you do the full backup/wipe/restore? I was clear that you had to do that as well. 9.3.2 and higher may be necessary but it is definitely not sufficient for most of us. Commented Aug 6, 2016 at 1:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .