1

I am using an Canon print workstation to send files to OS X. Unfortunately OS X El Capitan uses SMB3. It's no longer possible to send files scanned PDF files to OS X. How can I switch back to SMB1 for the OS X El Capitan SMB file service?

Update: The command isn't correct.

echo "[default]" >> ~/Library/Preferences/nsmb.conf; echo "smb_neg=smb1_only" >> ~/Library/Preferences/nsmb.conf

It sets the default network protocol to the slower but more reliable SMB 1 protocol. However I don’t want to connect to a SMB Windows file server. It’s the other way around. I am using the built-in OS X SMB file service (SMB3) and the printer connects to OS X.

Anyway, there aren’t many articles on how to force OS X SMB server to use SMB1. There is also a application SMBUp which replaces Apple’s OS X native netbios and SMB services. You can find a detail tutorial here
http://www.tweaking4all.com/os-tips-and-tricks/macosx-tips-and-tricks/smbup-mac-os-x-smb-fix/

Solution: Finally I said goodbye to SMB and switched to FTP file protocol.

  • Why would you want to do that? What is the problem that you are having? – Allan May 31 '16 at 1:11
  • 1
    Ahhh... Give this a try. It worked for Mavericks (SMB2) and should work here as well. In Terminal issue: echo "[default]" >> ~/Library/Preferences/nsmb.conf; echo "smb_neg=smb1_only" >> ~/Library/Preferences/nsmb.conf – Allan May 31 '16 at 10:49
1

I ran into this problem a few years back and I found the cleanest way was to install Samba (which still supports the older protocols) via Homebrew and use that instead of the version built by Apple.

I used these instructions, which are for Mavericks but I think they should still work for newer versions of OS X.

0

Your command sets the default network protocol to the slower but more reliable SMB 1 protocol. However I don’t want to connect to a SMB Windows file server. It’s the other way around. I am using the built-in OS X SMB file service (SMB3) and the printer connects to OS X.

Anyway, there aren’t many articles on how to force OS X SMB server to use SMB1. There is also a application SMBUp which replaces Apple’s OS X native netbios and SMB services. You can find a detail tutorial here
http://www.tweaking4all.com/os-tips-and-tricks/macosx-tips-and-tricks/smbup-mac-os-x-smb-fix/

Solution: Finally I said goodbye to SMB and switched to FTP file protocol.

  • You should move this clarification to the question part as it's technically not an answer but a clarification – Allan Jun 1 '16 at 10:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .