2

On El Capitan (10.11.4) I somehow got into a state where using the key combination shift+option+key outputs accented or special characters. For example

shift+option+k : 

shift+option+j : Ô

I have those key combos mapped to some useful commands in my text editor (RubyMine/IntelliJ), but instead of those commands working, I now just get the special character input. I assume it must be a built in OS X option (I've tried various keyboards) but I can't find any way to disable it. Any ideas?

  • Since option and option plus shift are always used by Apple for special characters by default, it's normally best to use control and command for shortcuts. Perhaps the Karabiner app can override that. – Tom Gewecke May 30 '16 at 22:51
  • It turns out that you need to create a custom keylayout in order to disable this. I followed the steps here: stackoverflow.com/questions/11876485/… – Geoff Evason Jun 6 '16 at 18:00
2

In order to avoid accented characters you need to create and use a custom keylayout file. I followed the steps outlined here:

https://stackoverflow.com/questions/11876485/how-to-disable-typing-special-characters-when-pressing-option-key-in-mac-os-x/24100077#24100077

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .