I got myself this WD 2TB USB3 external harddrive for backups: http://amzn.to/1X8b3a8

I connected it to the USB 3.0 port of my mid 2015 Macbook Pro 15".

When I run Time Machine, it really takes veeeery long for the backup (about 10-20 hours for a 350 GB initial encrypted backup).

So I ran disk speed test with this result. Is this speed normal and does Time Machine backup really take that long?

hd speedtest

  • This is measuring sequential write speed. Due to seek time and rotational latency, this is deceptively higher than the performance you'll see out of Time Machine (which is doing a very high number of writes of small files). See en.wikipedia.org/wiki/… – Alexander May 30 '16 at 16:34
up vote 2 down vote accepted

Time Machine and OS X is tuned to throttle the IO and possibly the CPU usage of the backup task. You can do a few things to modify that behavior - but from the speed benchmark and my experience - a 12 to 48 hour initial backup is not abnormal or indicative of slow backups once you have a few intervals backed up.

  1. You could log out and minimize other apps / changes to files to let the initial backup complete unhindered.
  2. You could interrupt the backup, erase the backup destination and tweak the io throttle settings and measure if this helps the initial backup.

To do the second, you'll ned terminal and want to review this excellent answer as well as some speculation on the web.

tmutil stopbackup
tmutil destinationinfo
tmutil removedestination DEB58ECE-531B-4295-85B4-82FC905A01EA
echo 'debug.lowpri_throttle_enabled=0' | sudo tee -a /etc/sysctl.conf

At that point, you would restart your Mac. When it restarts, then erase the USB 3 drive and establish it as the backup destination and start the initial backup again. There's no need to use the tmutil commands over the Time Machine preference if you like mouse control or visual feedback over terminal commands. The echo 'debug.lowpri_throttle_enabled=0' command needs to be run in terminal, though.

Lastly, you will need to change the removedestination command to command removal of your destination's unique ID instead of DEB58ECE-531B-4295-85B4-82FC905A01EA. Also, you might also see if your current backups are throttled and how they are doing work with:

sudo fs_usage backup

Unless you're really interested in analyzing the low level performance, I'd say you don't have a problem - just a slow initial experience - and revisit things in a week once the steady state backup timings are known. If you get hourly backups completing in 5 minutes or less - you probably shouldn't disable the debug timings as I listed above.

  • Also - jksoegaard is absolutely correct. The Black Magic benchmark measures bandwidth of sustained reads and writes. Time Machine workload is almost exclusively high IO / low bandwidth so benchmarking IOPS would be a better measure for checking tuning changes. That fact that IO service time is the limitation is what caused me to say you may not have a problem with your setup or choice of USB 3 drive. – bmike May 30 '16 at 14:32

The speed you see there is not unusual. I have seen various USB3 external harddrives vary from about 60 MB/s to about 120 MB/s. These speeds can be expected from ordinary hard drives - you'll to buy an SSD to get much higher speeds.

However please keep in mind that these speeds are the bulk transfer speed. I.e. if you transfer only one large file without any file system overhead, you would obtain these speeds.

A backup will contain lots of small files which are individually stored. The random access read/write speeds of these portable USB drives are usually much lower than the bulk speed.

Compared to my experience, it is not unusual for the first Time Machine back to take 10 hours.

Stop backing up and reboot then try this method.

Go to a Terminal and enter:

sudo sysctl debug.lowpri_throttle_enabled=0

For me, this sped it up from 72 hours to ~4 hours on a filesystem with 2.5 million files.

It’s also a good idea to re-enable the throttling after the initial backup has finished successfully with the following command:

sudo sysctl debug.lowpri_throttle_enabled=1

My case was solved.

  • actually, if you don't save the line debug.lowpri_throttle_enabled=0 to to the /etc/sysctl.conf file the system will use the default value of debug.lowpri_throttle_enabled=1 on the next reboot so it is only necessary to set it to =1 manually if you don't reboot your system regularly/right after finishing the initial backup run. – hyph Nov 9 at 15:24

The first backup will always take a long time. Possibly even overnight. Then it gets faster because it backups only modified files. I had the same speed with an Airport Time Capsule.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.