2

I have recently been getting a "No hardware installed" error when I attempt to enable WiFi. I have tried resetting the SMC, resetting NVRAM, reattaching the cables in the electronics of the computer. Now I am stuck for looking for solutions and I think maybe I need to get a new WiFi cable.

It’s a MacBook Pro 15" early 2011 running OS X  El Capitan. Is there any way to diagnose this?

1 Answer 1

1

...reattaching the cables in the electronics of the computer.

I am assuming by this statement, you have opened up your Macbook for whatever reason. Did you do any sort of service?

AirPort WiFi Bluetooth Adapter

Try reseating the Airport adapter - remove it completely and reinstall it.

There are 4 cables that go to this adapter. Three are the antenna cables (J0, J1, and J2) and the interface to the logic board (right)

In addition to that, you have the interface cable that connects it to the logic board (below). Notice the two connectors at each end.

AirPort Flex Cable

You have 4 things to check:

  1. The Airport card connector
  2. The cable connectors
  3. the cable itself
  4. The logic board connector

You will have to look closely. If you did any service to the MBP where removing these components was necessary, you may have damaged them either during removal or installation. Keep in mind these are very small and delicate components; the slightest force in the wrong direction can cause major damage.

The other scenario is that your Airport card simply failed; it happens. Replacement AirPort components are still available (as of February 2024)

If you damaged either the Airport card and/or the cable, you will have to replace them. The good news is that they are available on the open market for less than $50

If you damaged the connector on the logic board, you will need to have it fixed, get the logic board replaced, or get a USB Wifi Adapter like the Netgear USB dongles (I have personally used them with MacBook computers quite successfully).

4
  • Your statement "a broken cable would result in poor performance" confuses me. I can imagine a broken cable causing this - in fact I think that would be more likely than reduced performance, no? Edit: relevant to previous revision.
    – Tim
    May 27, 2016 at 22:49
  • See the updated post.
    – Allan
    May 27, 2016 at 22:50
  • So this method worked for about a week. I just reconnected all the cables. But now it isnt working, it has the error permanently
    – user185124
    Jun 11, 2016 at 3:03
  • The other scenario is that your Airport card simply failed; it happens...
    – Allan
    Jun 11, 2016 at 10:16

You must log in to answer this question.