2

I have a mid-2010 Macbook Pro running El Capitan (IP: 192.168.1.65) and a newer Macbook Air (~2014) (IP: 192.168.1.71) running El Capitan. Both are connected wirelessly to the same network: a U-Verse router (IP: 192.168.1.254). I have an Okidata MC362W (IP: 192.168.1.78) wired to the U-Verse router. All on a subnet of 255.255.255.0. The Macbook Air can print using CUPS without issue. The Macbook Pro prints OK until it doesn't also using CUPS and the Internet Printing Protocol. Then it will stop seeing the IP address. If I reboot the U-Verse, which takes more than 5 minutes, the Macbook Pro can then usually see the printer again until the same issue comes around 4 or 5 days later.

Here's what I've done:

  • I've assigned a static IP to the printer. The Macbook Pro is not using the same IP and it is not using the same IP of anything else on the network.
  • I've manually repaired permissions on the Macbook Pro
  • I've reset the printer settings on the MBP to default
  • I updated the firmware on the OKIDATA
  • I've uninstalled and re-installed the printer multiple times
  • I've installed the most up-to-date drivers for the printer
  • I've tried to print using Airprint -- it can see the printer, it cannot connect to the printer
  • I cannot ping the printer from the MBP nor can I access its IP through the browser.
  • To the best of my ability, the network setup on the Macbook Air and the MBP are identical

Does anyone have any suggestions of something new to try? TIA.

  • What IP's are in use locally? Please edit into your question the local IP's of both MacBooks, the printer, and the router. Subnet masks also especially anywhere you've set a static ip. – Tyson May 27 '16 at 20:53
  • @Tyson I've added the IP addresses in the question. – gushags May 27 '16 at 21:23
  • The printer and MB are both .78? Or is that a typo? – Tyson May 27 '16 at 21:25
  • Typo, already fixed. Sorry. One is .71, other is .78. – gushags May 27 '16 at 21:26
  • How did you assign the static address to the Okidata? – Allan May 27 '16 at 21:26
1

I solved the problem on my Mac. It was McAfee's firewall. It was blocking Bonjour communications... hence no printer sharing, or finding on the network. Disabled McAfee's firewall, and poof! Everything works.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .