I've noticed since upgrading to Lion that if I press Command-Control-Left/Right (and sometimes Down as well; see below), my computer beeps at me (plays alert sound).

It doesn't occur in all applications:

  • In Console, I can press any of the above key combinations, and there's no beep.
  • In Mail, it beeps if I press Command-Control-Left/Right, but not Up/Down.
  • In most every other application, every combination except Command-Control-Up causes a beep.

I can't seem to find any menu commands that it might be trying to invoke, although even if that were the case, applications such as NetBeans and PhpStorm are the proverbial monkey wrench here: I have Command-Control-Left mapped to "go to last edit". When I press that key combination, my Mac still beeps at me, but it it also does move the cursor to the last edit location.

What does Command-Control-Left/Right/Up/Down map to that my Mac is complaining about?

  • I ended up working around this issue in NetBeans/PhpStorm by changing the shortcut to Command-Option-Left.
    – user5118
    Commented Nov 30, 2011 at 21:14
  • 1
    You can also mute like superuser.com/questions/98868/… Commented Aug 7, 2014 at 4:01

4 Answers 4


The beeping you are hearing in this context is not because those key commands are mapped to something but quite the contrary because they are not.

Typing an unmapped key command will result in an audible bell.

As you note Command-Control-Right in results in an audible bell in Mail.app. You will also note that Command-N results in a new message.

So here's a proof to confirm my assertion:

  • Open System Preferences > Keyboard
  • Select Keyboard Shortcuts from the pillbox at the top
  • From the menu at the right choose Application Shortcuts
  • Click the small + sign at the bottom left of the right panel
  • From the Application pull down select Mail
  • In the Menu Title field type "New Message" (no quotes)
  • Place your cursor in the Keyboard Shortcut field and type Command-Control-Right
  • Click Add

Now return to Mail and type Command-Control-Right. A new message will be created but if you type Command-N you will hear the audible bell. This is because Command-N is no longer mapped to anything. We replaced it.

So when you hear the audible bell it often means that you are trying to do something that is not possible (i.e. typing a key command that has no meaning for the current application).

  • Interesting. That seems to make sense. Apps like NetBeans and PhpStorm seem to be an exception to this rule, but they do implement their own shortcut handling, so it's possible that they are simply not doing it properly.
    – user5118
    Commented Sep 2, 2011 at 22:52
  • 10
    I see the same thing with all the JetBrains apps. It's driving me nuts :(
    – Shane
    Commented Jan 1, 2012 at 0:55
  • 9
    IntelliJ is precisely why I'm here...
    – dev
    Commented Mar 28, 2015 at 14:01
  • Kind of weird that just because something isn't bound in the System Prefs that MacOS assumes the key combo isn't used, when it could easily be mapped to something important in a 3rd party application, like in an IDE or text editor for example. Commented Mar 15, 2018 at 23:31
  • 1
    roNn23's answer fixes the problem in JetBrains tools like IntelliJ, PyCharm, CLion, AppCode, Ryder, etc.
    – rob mayoff
    Commented Dec 13, 2019 at 23:16

Depending on the version of your macOS, you have to do the following:

10.11 El Capitan through 13.0 Ventura (from Adobe/Brackets)

You'll need to create the ~/Library/KeyBindings directory first. Then create the file ~/Library/KeyBindings/DefaultKeyBinding.dict with the following content. Restart the app or the Mac after saving this file.

    "@^\UF701" = "noop:";
    "@^\UF702" = "noop:";
    "@^\UF703" = "noop:";

<= 10.10 Yosemite (Found on GitHub/Atom)

Create the file ~/Library/KeyBindings/DefaultKeyBinding.dict with the following content. Restart the app or the Mac after saving this file.

    "^@\UF701" = "noop:";
    "^@\UF702" = "noop:";
    "^@\UF703" = "noop:";
  • 2
    i had to switch @ and ^ on ElCapitan "@^\UF701"
    – GDmac
    Commented Mar 24, 2017 at 15:23
  • This answer fixed the problem for me (in CLion and other JetBrains tools) on macOS 10.15 Catalina with no changes.
    – rob mayoff
    Commented Dec 13, 2019 at 23:17
  • 1
    Still works in Catalina! But maybe you have to restart the app or the Mac if it doesn't work right away.
    – roNn23
    Commented Mar 24, 2020 at 11:32
  • For Catalina and VSCode the first worked for me, while the second did not!
    – mdcq
    Commented Nov 5, 2020 at 15:08
  • 1
    @philmcole Thanks! I've corrected the answer :)
    – roNn23
    Commented Nov 15, 2020 at 14:51

If you want Command+Alt+Control+arrow to also suppress the chime, use this:

"@~^\UF701" = "noop:";
"@~^\UF702" = "noop:";
"@~^\UF703" = "noop:";

(only tested in Monterey)


If you have issues with control+option+command+arrow as well, then also add these: (tested with Monterey)

    "@~^\UF701" = "noop:";
    "@~^\UF702" = "noop:";
    "@~^\UF703" = "noop:";

Don't forget to close and re-open the app that you are using to see the effects!

You must log in to answer this question.