1

I have a rather weird problem with my desktop of my MacBook Pro. I use El Capitan 10.11.15.

For reasons I don't know I'm no longer able to keep more than one running application visible at the time.

For example, if I start Terminal, it opens. But when I start TextEdit, Terminal will hide or minimize and TexEdit will become visible instead. The same goes for every other application.

When I open Mission Control, it also shows only one active window, no matter how many other applications are running.

I must have accidently activated it but cannot recall how. I've tried playing around with Dock and Mission Control settings, but nothing changed it.

Does anyone know how to get it back to normal so that I have more than one window/application visible at the same time?

2

This answer lifted in its entirety from Super User : Snow Leopard desktop - I want two files from two different applications open at the same time. Won't let me

Have you per chance turned on "Single App Mode"? This hidden preference causes Mac OS X to hide all applications but the current active one.

You can tell by running the following command in Terminal.app:

defaults read com.apple.dock single-app

If it prints a 0then it is not turned on. If it prints a 1 then yes, it is turned on.

You can disable this trick by running:

defaults write com.apple.dock single-app 0
  • Thanks for your answer. I just checked and Terminal told me it was turned off (0). Anything else I can try? – thaikolja May 25 '16 at 14:42
  • 1
    The only other possibility [however remote] that I can think of is that your Opt/alt key is sticking. – Tetsujin May 25 '16 at 15:07
1

After fiddling around for hours, I found out what had caused this bug. It was one of the autostart elements. I don't know exactly which one it was, but after removing all and only adding what I really needed, all worked fine.

  • I eventually did find it out. The issue was caused by Keyboard Maestro. In its "General Settings", the option "Always Hide Other Applications" must be unchecked. Here's a screenshot: i.imgur.com/ngOfw7R.jpg – thaikolja May 25 '16 at 20:49
0

On Mac OS X High Sierra, the problem was solved for me by deactiviting LiteSwitch X. Go into System Preferences and LiteSwitch X should be on the bottom row. Open it and you can disable the app.

  • There is already an accepted answer to this question which has nothing to do with the app you mention. In fact, it was a completely different app altogether which caused the problem. – IconDaemon Nov 9 '17 at 23:10
  • @Icon That's not a problem, this answer is not repeating a solution already provided – grg Nov 10 '17 at 0:05
0

I had my Opt key pressed causing the windows to hide when others activated. Leaving this here in case someone else comes across it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .