Process "mtmfs" is using 98% of cpu, heating up the core and runing the fans flat out.

I have quite the process through activity monitor, but does anyone know a longer term solution?

I am running a MacBook Pro 2.2 GHz Intel Core i7 with 8GB RAM and OS 10.7.1

  • 1
    Is your Console spitting out errors about Time Machine, per this Apple forum? discussions.apple.com/thread/3201661
    – user479
    Commented Sep 2, 2011 at 5:04
  • No console did not seem to be spitting out errors. But I will keep an eye out for this - Thanks
    – crispinb
    Commented Sep 28, 2011 at 0:39
  • Are you using a time capsule or some other type of network based destination? I ask because I have the same issue with my personal Macbook at home but not my work MBP. The work MBP uses an external USB drive, but the Macbook uses a network share to a mac mini.
    – Dustin
    Commented Oct 2, 2011 at 18:35

2 Answers 2


Presumably you're using Time Machine? mtmfs is Mobile Time Machine file system daemon. Have you tried disabling Time Machine?

  • 1
    sudo tmutil disablelocal will switch off this local process, and delete all local copies of data stored in Time Machine. Do look in the console log to check for errors as well, but disabling the local and a reboot should clear the CPU usage if you don't want local backups.
    – bmike
    Commented Sep 2, 2011 at 13:27
  • 2
    Yes I know time machine is behind this! I have now installed "Time Machine Scheduler" and this has solved the problem. Thanks for your help!
    – crispinb
    Commented Sep 28, 2011 at 0:37
  • Please either accept this answer, or add your own to close the question. Glad it could be resolved.
    – user479
    Commented Sep 28, 2011 at 5:51
  • I do have local backups enabled and never got high CPU. Im wondering if the problem is somewhere else ?
    – latusaki
    Commented Apr 4, 2012 at 12:18

I was running a search on EasyFind and forgot about it - started up Clean My Mac 2 - this is when mtmfs started cranking up my CPU/fan. I quit EasyFind and the CPU % went down immediately. Took a few minutes for fan to slow down. I think maybe the two programs running a thorough search at the same time did it. Haven't had a problem with either one when run alone.

Not the answer you're looking for? Browse other questions tagged .