0

I have a MacBook Pro (Retina, 15-inch, Mid 2015, OS X El Capitan, 10.11.5) with Intel Iris Pro 1536 MB connected to an external monitor:

Samsung SE790C:

  • Resolution: 3440 x 1440 @ 60 Hz
  • Pixel Depth: 32-Bit Color (ARGB8888)
  • Mirror: Off
  • Online: Yes
  • Rotation: Supported
  • Connection Type: DisplayPort
  • Television: Yes

Every time my MacBook wakes up from sleep, all my windows are back to the MacBook screen. I have a similar setup at home (same MacBook but with a Dell 26' monitor) and this does not happen.

Anything I can do about that? If more info is needed, just let me know! Thanks in advance for any help on that!

1

I found the answer after pulling my hair for a few days...

I actually had to tick the "Displays have separate Spaces" option in System Preferences => Mission Control

Does this setting depend on the monitor that is plugged in? I would suppose the answer is yes, otherwise it would not work with my home monitor... To be tested and confirmed!

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .