1

On my old laptop, which ran Snow Leopard, I had it set to not play system sound effects. As far as I remember, all I did to achieve this was go to System Preferences -> Sound -> Sound Effects tab -> uncheck "play user interface sound effects". This worked well - my laptop never made a sound unless I explicitly told it to.

I have done the same thing on my new El Capitan laptop, and this does seem to have disabled some sound effects, but nevertheless my computer still makes a "bonk" sound in some situations. For example:

  • In XCode, it happens if I press Shift-CMD-Z when there is nothing left to redo.
  • In Finder, it happens if I try to paste a file into a folder for which I don't have write permissions, or if I press CMD-S while a Finder window has the focus.
  • A few times it's happened seemingly at random, probably due to me accidentally triggering a trackpad gesture.

This runs the risk of embarassing me in a meeting, giving me an unwelcome surprise if plugged into an amplifier, etc. Is there a way in El Capitan to completely disable all sound effects, except for the ones generated by games, music programmes etc. that I explicitly ask for?

  • You could just mute it and unmute when you want – jaydm26 May 24 '16 at 7:51
  • @jaydm26 if I'm working on an audio-related task (as I often do) then that's not an option. I'm also quite likely to have it hooked up to an amp in such situations, when I especially don't want the "bonk" sound. I'm also sure everyone occasionally forgets to mute their computer after a Skype call etc. I'm looking for a "real" solution much more than for hints or workarounds. – Nathaniel May 24 '16 at 7:56
  • Any reason for the downvote? The answer was simple, but IMHO not obvious. Surely one should expect that if "play user interface sound effects" is unchecked, then user interface sound effects would not be played. Having to also turn their volume down, in addition to turning them off in the first place, seems a rather strange user interface quirk, and worth having a Q&A about. – Nathaniel May 26 '16 at 1:12
4

Turn down the alert volume

System Preferences---> Sound---> Sound Effects

This should mute the "bonk" sound you get when you do the things you mentioned

I am on 10.10.5. I hope the setting haven't changed.

  • Thank you! Despite visiting that dialogue several times, I'd completely failed to notice there was even a slider there. That does appear to have worked. – Nathaniel May 24 '16 at 13:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .