3

This week my El Capitan system reported that the Flash player was out of date. So I did the usual thing and went to Adobe, downloaded the latest (21 A) installer and kicked it off. After entering my password, the installer went through the usual "downloading .." part and commenced on the installation part, at which point it failed, showing me this:

Adobe Flash Player: Installation failed.

What I did was the same as I had done many times before, but this time it failed - and I tried multiple times and also downloaded the installer multiple times.

Any ideas?

  • Have you tried restarting your mac and trying again? – fsb May 23 '16 at 13:36
  • @fbara I started this dance last week and have restarted my mac multiple times since then. – Peter M May 23 '16 at 13:41
1

I had this problem on & off for years, it's something to do with my firewall, which I've never been prepared to fiddle with just so I can get an online installer to function properly.

The simplest workaround is to go get the full downloadable .dmg version instead of the online installer.

For the past few years, it's been located at http://www.adobe.com/uk/products/flashplayer/distribution3.html
or you can Google "adobe flash player offline installer download" which always finds it.

I did eventually find a solution to my Flash problems...
... I uninstalled Flash from every machine in the building ;-)

  • I wish I could uninstall flash but there are several sites that I regularly peruse that still use flash. I also have shutdown my firewall to no avail, so I'll give this a shot. – Peter M May 23 '16 at 14:39
  • BTW .. from that link "This page and the download links will soon be decommissioned and will be replaced by a new Adobe Flash Player distribution portal that will require a valid distribution license to access." – Peter M May 23 '16 at 14:41
  • btw, I think it's the 'administrator's version you need. If you get it to work, could you confirm that & I'll add it to my answer. – Tetsujin May 23 '16 at 14:41
  • Yes, I spotted the notice... & wondered if they'd wait for most of the rest of the world to stop using Flash altogether... ;) – Tetsujin May 23 '16 at 14:43
  • I tried both installers and I believe that both worked for me - assuming that the Adobe uninstaller actually completely cleaned out Flash between my tests. I did note that after installing the admin version that I had to manually turn on flash in the Safari preferences. I then uninstalled that version and installed the non-admin version and saw that Flash was already turned on. I don't know if this was carrying through from the previous test. – Peter M May 23 '16 at 15:19
0

I had the same problem and after hours of installing, rebooting, and dredging through archives, I finally solved the problem by opening Library > Internet Plugins and dragging Flash Player plug in and flashplayer.xpt in from an old backup. And hey presto, Flash Player is back.

  • Where did you open Library > Internet Plugins and where did you drag flashplayer.xpt. Please elaborate on what you did so it is more accurate. – Allan Jul 14 '16 at 20:56
0

I had the same problem, updating Flash in OS X 10.11.6 (El Capitan), and the solutions posted here didn't work, including the accepted solution from May 2016 pointing to "distribution3.html" at Adobe, which currently (Nov 2016) redirects to a new page providing only the web installer. After multiple searches, I learned that that page had a deprecation message on it for about a year before Adobe removed it and redirected.

Annoyingly, the place to go for a fix appears to be an ever-moving target—Adobe's way to help us all love Flash even more. As of early Nov 2016, the full download version is here:

Installation problems | Flash Player | Mac

Who knows where it will be next month. The self-contained installer there (18.9 MB) worked without problems for me. Find it in the "Still having problems?" section near the bottom of the page.

-1

I had the same issue. I installed OS X Sierra and then installed Flash again without any problem.

-3

Ensure you enable Active Scripting - select Internet options, security, scripting, active scripting (last option at bottom of list). This fixed it for me.

Cheers.

  • This seems to be Windows advice and nothing to do with OS X – Peter M Aug 8 '16 at 11:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .