1

Since a week or so, I have a very strange issue on my Mac... I can login from the login screen, but any further action that requires my password fails: from a terminal if I try to sudo, or from any system preferences pannel that prompts for my password. I cannot add "Show Input menu in login window" because this requires to enter my password... I have only one keyboard configured in System preferences so it is not even an issue of different keyboard layout as far as I can tell. And since my account is not bound to my appleid (and I need my password to do it) I am really stuck...

Is formatting the only option ?

  • Don't follow piece of advice which is not coming from someone who understood your problem. – dan May 23 '16 at 11:56
  • To be clearer: No, formatting isn't an option, this is an advice from a bad genius :). – dan May 23 '16 at 16:44
0

Open Textedit and type there your password to check which problem might be yours:

  • typing errors,
  • bad repeating tuning,
  • num lock,
  • keys problems,
  • session configuration error.

If you think you have a typical problem with just the login window, just configure your login so as to take advantage of your name part of the login window to check how your keyboard and your software are behaving. Configure System Preferences > Users & Groups as follows: System Preferences > Users & Groups

Within the Name: part of the login window, type all the characters contained in your password and check for:

  • bad repeating tuning,
  • num lock,
  • keys problems.
  • I tried all this, but always the same issue: if I log out and enter my password, it works. As soon as I am logged in, I cannot enter my password anymore. – CanardMoussant May 23 '16 at 11:59
  • By "all this" do you mean that you were able to type your password within Textedit with no problem? – dan May 23 '16 at 12:25
  • Sorry I read what you put too quickly. My password contains a '!' and a '^' on a US keyboard (behind the 1 and 6) so the errors may come from here. But it is not a numlock issue since I tried with and without caps lock to be sure (and I also rebooted the mac many times). I am not sure what I can do.... – CanardMoussant May 23 '16 at 13:35
  • Hallelujah ! Apparently the ^ character is not considered from the login screen, so I just removed it... Thanks !! – CanardMoussant May 23 '16 at 13:45
  • Do you mean your password was password^ and in fact the login screen was only reading password? – dan May 23 '16 at 16:22
-1

Sometimes keychain is broken. Try to reset password

Please don't forget to make backups.

  • Hello. As you are new, I would like to remind you that it is best to tell how to reset a password in the answer, not by linking to another page. – haykam May 23 '16 at 11:11
  • Unfortunately FileVault is off, I did not connect my AppleId, and there is no other admin account... – CanardMoussant May 23 '16 at 12:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .